О движке

Общая информация по движку

 Return to Introduction

DataLife Engine v.10.0 - это многопользовательский новостной движок, обладающий большими функциональными возможностями. Движок предназначен, в первую очередь, для создания новостных блогов и сайтов с большим информационным контекстом. Однако он имеет большое количество настроек, которые позволяют использовать его практически для любых целей. Движок может быть интегрирован практически в любой существующий дизайн и не имеет никаких ограничений по созданию шаблонов для него. Еще одной ключевой особенностью DataLife Engine - является низкая нагрузка на системные ресурсы. Даже при очень большой аудитории сайта нагрузка не сервер будет минимальной и вы не будете испытывать каких-либо проблем с отображением информации. Движок оптимизирован под поисковые системы, что приведет на ваш сайт дополнительных клиентов. Использование продвинутой технологии AJAX позволит вам сэкономить вам ваш трафик и трафик посетителей, а также снижает нагрузку на сервер.


Общие Возможности

DataLife Engine обладает следующими возможностями:

Общие возможности:

? Использует для хранения данных MySQL
? Минимальная нагрузка на базу данных
? Использование продвинутой технологии AJAX
? Вывод новостей, статей, да и вообще всего что угодно
? Поддержка ЧПУ (человеко-понятный URL) позволяет использовать тему статьи или любой другой текст в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной (необходим modrewrite)
? Возможность отключения ЧПУ
? Общая статистика сайта
? Поддержка дополнительных полей (возможность использовать не только краткую и полную новость на сайте, но и имеется возможность для создания любого количества дополнительных полей различных видов для ввода информации)
? Возможность написания статей, содержащих несколько страниц
? Флуд контроль
? Автоматический фильтр слов в комментариях
? Поддержка категорий
? Возможность установки любого количества вложенных категорий
? Каждой категории можно назначить отдельный шаблон
? Автоматическое обрезание длинных слов в комментариях
? Рейтинг новостей
? Календарь
? Поиск по статьям включая дополнительные поля (подсветка найденного текста)
? Обзор непрочитанных новостей с момента последнего посещения сайта
? Возможность просмотра сколько раз была прочитана новость
? Возможность добавления статей в раздел "Избранное"
? Отсылка писем пользователям через форму на сайте
? Вывод страницы используя сжатие gzip
? Поддержка персональных сообщений между пользователями
? Поддержка нескольких языков
? Вывод популярных статей в отдельном блоке
? Возможность создания статистический страниц непосредственно через админпанель
? Возможность выбора между упрощенной регистрацией и расширенной, при выборе расширенной регистрации пользователь будет зарегистрирован только после активации аккаунта. Активация высылается по почте.
? Возможность загрузки и прикрепления файлов к новостям
? Встроенные средства защиты от несанкционированного скачивания файлов (antileech)
? RSS Импорт новостей
? RSS Информеры
? Мультиязычная поддержка новостей на сайте
? Поддержка Облака Тегов
? Автоматическая поддержка смартфонов

Возможности для посетителей сайта:

? Регистрация на сайте
? Добавление комментариев
? Изменение и удаление пользователями своих собственных комментариев
? Возможность добавления новостей со стороны посетителей
? Модерирование новостей
? Статистика по конкретному пользователю (включая рейтинг и профиль)
? Вывод различной информации для зарегистрированных посетителей и нет
? Возможность загрузки фотографии в профиле пользователя
? Возможность восстановления забытого пароля
? Возможность редактирования новости непосредственно на сайте
? Смена скинов на сайте по своему усмотрению
? Ведение закладок для новостей, и быстрый доступ к ним.
? Массовая загрузка картинок на сервер
? Просмотр и добавление видео на сайт
? Персонализация вывода рекламы для определенных групп
? Возможность загрузки большого количества картинок и файлов в один клик
? Система жалоб "в один клик", на ошибки, новости, комментарии, персональные сообщения

Возможности админцентра:

? Добавление, редактирование и удаление новостей
? Полностью настраиваемая админпанель для различных групп пользователей
? Возможность использования двух редакторов (BBCODES или WYSIWYG)
? Антивирус проверяющий состояние файлов на предмет возможного взлома
? Редактирование пользователей
? Имеется возможность использовать смайлы и HTML код
? Неограниченное создание групп пользователей с тонкой настройкой различных прав доступа
? Возможность выставления бана для посетителей
? Средства для создания и редактирования шаблонов непосредственно в админцентре
? Возможность корректировки времени
? Возможность изменения даты публикации
? Автоматическая публикация статьи при наступлении установленного времени
? Возможность отключения календаря и архивов (для экономии ресурсов)
? Возможность фиксации новостей (будут всегда наверху, независимо от даты)
? Отключение регистрации посетителей
? Автоматическая временная приостановка регистрации при достижении максимального количества зарегистрированных пользователей
? Автоматическое уменьшение загруженных картинок с сохранением пропорций до указанных размеров
? Автоматическое удаление пользователей которые не посещали сайт заданное время
? Наложение водяных знаков на картинки
? Возможность загрузки картинок для каждой конкретной новости (при удалении новости, картинки тоже будут удаляться)
? Удобный менеджер загруженных картинок
? Оптимизацию, ремонт, создание резервной копии и восстановление базы данных можно осуществлять непосредственно из скрипта
? Поиск пользователей по IP адресам
? Удобное управление рекламными материалами.
? Быстрый поиск и замена в базе данных
? Публикация "правил" на сайте
? Создание карты сайта для Google
? Создание фильтров для автоподстановки слов и значений

И много других полезных функций...


Список изменений

Список изменений относительно версии 9.8:

q Вместо устаревшего шаблона для мобильной версии сайта, добавлен абсолютно новый шаблон smartphone.
q Добавлена новая система защиты сайта от спамеров. Новое решение основывается на облачном сервисе stopforumspam.com, который содержит информацию о более чем 45 миллионах спамерах по всему миру. Благодаря данной возможности осуществляется автоматическое блокирование более 90% промышленного спама. Контроль спамеров осуществляется при регистрации пользователей на сайте, при публикации комментариев и при использовании обратной связи на сайте, при отправке писем обычным посетителям сайта. Данная возможность включается в настройках скрипта в админпанели и вы можете включить как умеренную фильтрацию спама, так и усиленную. При включении умеренной фильтрации производится интеллектуальная проверка, является ли пользователь спамером или нет, при этом учитывается как давно IP или e-mail участвовал в спаме и когда было последнее сообщение о спаме со стороны данного пользователя, и на основании этого принимается решение о том является он спамером или нет. Умеренная фильтрация позволяет более гибко избегать ошибочных срабатываний, когда пользователь не распространял спам, а IP ему достался от интернет провайдера, тот, который раньше использовался спамером. При включении усиленной фильтрации в настройках скрипта, осуществляется полное и безоговорочное блокирование IP адресов замеченных в спаме.
q В настройки скрипта добавлена возможность подключения вашего сайта к всеобщей борьбе с мировым злом: спамом. Для этого вы можете зарегистрироваться на сервисе stopforumspam.com, получить API ключ, и задать его в настройках скрипта. После этого если в комментариях вы нажимаете на кнопку "Спам", то помимо удаления спамерских комментариев, будет осуществляться отправка всех данных спамера в общую базу данных о спамерах, тем самым вы поможете автоматически блокировать спамера на других сайтах. Данная настройка является необязательной, и вы можете пользоваться блокированием спамеров на своем сайте из без получения API ключа, однако мы рекомендуем всем администраторам зарегистрироваться и получить API ключ, и активно пользоваться кнопкой "Спам", для удаления именно спама на сайте. Тем самым вы примете активное участие в борьбе со спамом, что в свою очередь позволит вашим же сайтам быть более защищенными от спама.
q При добавлении новостей на сайте добавлена возможность публиковать также сразу и опрос к добавляемой новости.
q Полностью переписаны все регулярные выражения для функций preg_replace в скрипте, использующий модификатор /e. Все данные функции были заменены на использование preg_replace_callback. Данное изменение кода было произведено в целях обеспечения совместимости DLE c линейкой PHP 5.5.x
q Переписан модуль создания бэкапа базы данных MySQL, вместо устаревшего расширения MySQL, бэкап создается и восстанавливается при помощи более нового расширения PHP MySQLi. Это необходимо для поддержки новой линейки PHP 5.5.x
q В админпанели для раздела "Список действий в админпанели" добавлена возможность просматривать неудачные попытки авторизоваться в админпанели скрипта, либо неудачные попытки авторизации пользователей на сайте, имеющих доступ к админпанели. Тем самым в случае попыток подбора пароля к аккаунту методом перебора, вы можете видеть данные попытки, и оперативно реагировать на них.
q Для RSS импорта публикаций в админпанели и для RSS информеров, добавлена поддержка формата Atom http://ru.wikipedia.org/wiki/Atom, тем самым вы можете импортировать себе на сайт ленты, содержащие публикации не только в формате RSS 2.0, но и в формате Atom.
q Для страниц использующих показ новостей главной страницы добавлено использование канонических ссылок, позволяющих устранить дубли главной страницы в поисковиках. Например, адреса http://site.ru/ и http://site.ru/index.php представляют собой разные адреса одной и той же главной страницы. При этом для страницы дубля http://site.ru/index.php будет установлен тег , указывающий поисковой системе, какой адрес главной страницы предпочтителен.
q Добавлена возможность учитывать не только все просмотры публикаций, но и только уникальные просмотры. Для этого в настройках скрипта для счетчика просмотров новостей предоставляется выбор: либо вы можете полностью отключить счетчик просмотров новостей, либо учитывать все просмотры публикации (счетчик просмотров увеличивается при каждом обращении к новости), либо вы можете включить учет только уникальных посетителей (счетчик просмотров привязывается к IP посетителя и если данный пользователь уже просматривал новость, то второй просмотр от него уже не учитывается).
q Для модуля вывода быстрой навигации 'speedbar' (хлебные крошки), добавлена микроразметка HTML для поисковых систем, позволяющая более информативно показывать ссылки на ваши сайты в найденных результатах. Более подробно о данной микроразметке вы можете прочитать на странице http://support.google.com/webmasters/bin/answer.py?hl=ru&answer=185417
q В настройки скрипта в админпанели, добавлена возможность включать отправку писем в обратной связи с использованием системного E-mail адреса администратора. Данная настройка полезна при использовании бесплатных SMTP серверов и некоторых хостинг провайдеров, где ограничено использование поля From при отправке писем, на использование только конкретных адресов, например, разрешено использовать только адреса зарегистрированные на сервере, с помощью которых осуществляется отправка писем. При включении данной настройки, сообщения в обратной связи на сайте будут приходить от имени системного e-mail адреса, а непосредственно E-mail адрес отправителя письма вы можете задать в шаблонах E-mail сообщений в админпанели при помощи тега {%email%}
q В настройки скрипта добавлена возможность включения отправки E-mail уведомлений на системный E-mail адрес администрации сайта, при получении новых жалоб на сайте от посетителей вашего сайта.
q Для страниц просмотра полной новости добавлена специальная разметка в метатегах согласно протоколу Open Graph http://ogp.me/, благодаря ей, для социальных сетей и поисковиков, в метатегах будут добавляться название сайта, ссылка на изображение новости, ссылка на видео (если таковое присутствует в новости и опубликовано при помощи тега [video]), а также ссылка на аудио (если таковое присутствует в новости и опубликовано при помощи тега [audio]). Все это позволяет более лучше и качественнее индексировать ваш сайт и интегрировать его с социальными сетями.
q Для тега пользовательского вывода публикаций {custom ...} для атрибута category="...", добавлена поддержка указания диапазона категорий с использованием тире. Например, тег {custom category="1,4-8,11" aviable="global" from="0" limit="10" order="date"} выведет новости из категории 1, категорий имеющих id c 4 по 8, а также из категории 11. Тем самым упрощаяется написание большого количества категорий в теге.
q Добавлена новая система ресайза и наложения водяных знаков на изображения в формате GIF, что привело к более корректной поддержке картинок, содержащих прозрачность.
q В настройки скрипта добавлена возможность установки времени для принудительной очистки кеша. Вы можете установить интервал времени в минутах, по истечении которого кеш скрипта будет очищен принудительно. Данная функция будет особенно полезна для сайтов, которые заранее публикуют новости на еще не наступившее время, и используют при этом кеширование на сайте. Для данной настройки можно задать значение 0, тогда кеш будет очищаться, как и ранее автоматически по мере изменения информации в базе данных.
q В админпанели скрипта, в разделе управления дополнительными полями новостей, добавлена новая удобная система установки порядка сортировки. Теперь для того чтобы установить новый порядок сортировки, достаточно будет перенести нужные поля мышкой в необходимые позиции и сохранить порядок сортировки. Данная новая система позволяет намного удобнее организовывать списки дополнительных полей для новостей.
q Для дополнительных полей новостей, имеющих тип "несколько строк" добавлена возможность указывать подключать или не подключать редактор при написании публикаций для данных полей. Тем самым вы можете более гибко использовать данное поле для различных целей.
q Глобальная настройка "безопасный режим дополнительных полей", которая отключала поддержку BB тегов и HTML в доп. полях была перенесена непосредственно в управление дополнительными полями. Теперь вы можете установить для каждого поля отключать или нет BB теги и HTML. Тем самым вы можете более гибко использовать поля, например для нужных полей имеющих тип "одна строка", вы можете разрешить использование в нем BB тегов.
q В админпанели скрипта, в разделе управления дополнительными полями профилей пользователей, также добавлена новая система установки порядка сортировки. Теперь для того чтобы установить новый порядок сортировки, достаточно будет перенести нужные поля мышкой в необходимые позиции и сохранить порядок сортировки. Данная новая система позволяет намного удобнее организовывать списки дополнительных полей для профиля пользователей.
q В настройки скрипта добавлена возможность указывать какой именно контент показывать по умолчанию на главной странице. Вы можете выбрать показ новостей при помощи тегов {content} или {custom}, а также выбрать показ статической страницы на главной. При этом, несмотря на то, что показ новостей определяется наличием тегов {content} или {custom} в шаблоне, если вы на главной странице выводите только новости через тег {custom}, то данный пункт также необходимо выбрать в настройках скрипта, потому как это позволит сэкономить на ресурсах вашего сервера и скрипт не будет выполнять лишнюю работу по обработке для тега {content} для главной страницы вашего сайта.
q Добавлена возможность использования одновременно тегов [xfvalue_x] и [xfvalue_x limit="X"] в шаблонах вывода кратких и полных новостей.
q Добавлена возможность удаления зарегистрированных пользователей, непосредственно при редактирования их профиля на страницах сайта. Тем самым для удаления пользователей, нет больше необходимости копировать их логин с сайта и заходить в админпанель в раздел редактирования пользователей, необходимые действия можно выполнить, находясь непосредственно на страницах сайта.
q Для пользовательского вывода новостей при помощи тега {custom}, для атрибута fixed="yes", добавлена возможность использовать значение only, которое выводит только зафиксированные новости из раздела. Например, если указано fixed="yes" то зафиксированные новости будут выводиться первыми, а потом все остальные, а если указано fixed="only", то будут выводиться только зафиксированные новости.
q Для шаблонa вывода популярных новостей (topnews.tpl) добавлен новый тег {title limit="x"} который выводит урезанный до X количества символов, заголовок новости. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова.
q Для шаблонов вывода популярных новостей и похожих новостей (topnews.tpl и relatednews.tpl) добавлена поддержка новых тегов: {date} и {date=формат даты}, которые выводят дату новостей либо согласно настройкам скрипта, либо в пользовательском заданном формате.
q Добавлена константа SECURE_AUTH_KEY в файле engine/data/dbconfig.php. Значение данной константы генерируется автоматически и является уникальным для каждого сайта. Константа представляет из себя сложную строку из различных букв, цифр и спецсимволов, длиной более 60 символов и предназначения для усиления различных хешей и контрольных подписей сайта. Внедрение данной константы защищает сайт от расшифровки контрольных хешей методом перебора. В любое время, при желании, администратор может изменить значение данной константы по своему усмотрению.
q Настройки групп, разрешающие загрузку картинок и обычных файлов на сервер, стали полностью независимыми друг от друга. Например, вы можете разрешить загрузку файлов на сервер, определенных расширений, но при этом запретить загрузку картинок на сервер.
q Внесены изменения в рассылку массовых сообщений пользователям в админпанели скрипта. При отправке рассылки массовых сообщений в админпанели, сообщения больше не будут отправляться забаненным пользователям на сайте.
q Улучшены механизмы возобновления отправки рассылки массовых сообщений в админпанели. Ранее при возобновлении могла происходить повторная отправка уже отправленных писем, либо возобновление было невозможно.
q Оптимизирована загрузка JS скриптов, предназначенных для обмена посетителями ссылками на сайт и публикацией их в социальных сетях, уменьшен код этих скриптов и добавлена поддержка GZIP сжатия для данных скриптов, что существенно ускоряет их загрузку браузером посетителя вашего сайта.
q Внесены небольшие косметические изменения в формирование ББ тега спойлера, добавляющие кликабельность для картинки открытия, закрытия спойлера.
q Улучшен контроль неверных ЧПУ ссылок на страницах пагинации главной страницы сайта.
q Обновлен WYIWYG Live Editor до актуальной версии.
q Исправлена проблема, связанная с некорректной работой BBCODES редактора в браузере IE9 при добавлении новостей и комментариев на сайте.
q Исправлена проблема, при которой терялась часть вопроса в разделе редактирования вопросов и ответов, еcли данный вопрос содержал кавычки.
q Исправлена проблема, при которой не происходил учет фильтра слов в момент регистрации пользователя на сайте, тем самым слова из фильтра допускались в информации о себе в момент регистрации пользователя на сайте.
q Исправлена проблема, связанная с некорректным добавлением лишних span тегов в WYSIWYG LiveEditor редакторе, при работе в нем в браузере Chrome, во время объедения различных строк текста.
q Исправлена проблема, при которой в случае изменения пользователем своего e-mail адреса в профиле, уведомления о новых комментариев на подписанные новости, продолжали приходить на его старый адрес.
q Исправлена проблема, связанная с добавлением флэш роликов в визуальном редакторе LiveEditor.
q Исправлена проблема, связанная со вставкой одинарных и двойных кавычек при полном цитировании комментариев.
q Исправлена проблема, связанная с некорректным формированием ссылки на профиль пользователя при отключенном ЧПУ, которая формируется в разделе просмотра статистики сайта.
q Исправлена проблема, связанная с возможной некорректной сортировкой статических страниц по дате, в админпанели скрипта.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.7:

q Для администрации сайта добавлены новые механизмы для быстрой борьбы со спамерами в комментариях. Для этого в шаблоны вывода комментариев добавлены теги [spam] Спамер [/spam], которые выводят текст, указанных в них, в виде ссылки, при нажатии на которую происходит отметка посетителя, оставившего комментарий как "спамера". При этом если пользователь отмечается как "спамер", все его комментарии автоматически удаляются с сайта, а самому посетителю запрещается в дальнейшем публикация новостей и комментариев на сайте, а если комментарий был добавлен от имени гостя, то его IP помещается в список заблокированных для доступа к сайту. Тем самым администрация сайта может удалять все комментарии спамера и блокировать ему доступ к добавлению новых комментариев всего в один клик. Доступ к отметке пользователя как "спамер" имеют группы пользователей, которым разрешен доступ к админпанели и которым разрешено удаление любых комментариев в настройках групп.
q В админпанели при редактировании новостей, находящихся на модерации, для администраторов и редакторов сайта добавления кнопка "Спам", при нажатии на которую администрация может отметить пользователя, отправившего новость на модерацию, как "спамера". При этом все другие новости данного пользователя, находящиеся на модерации будут удалены, а самому пользователю будет запрещено добавлять новости и комментарии на сайте в будущем. Данная возможность позволяет также в один клик удалить спамерские новости, а самого пользователя ограничить в правах.
q При просмотре посетителем полной новости на сайте, добавлена возможность отметить интересные фрагменты текста на странице и получить уникальный url с размеченными фрагментами. Таким образом, любой желающий может, выделив в тексте нужные части (параграфы, предложения или слова), поделиться с кем-либо сгенерированной уникальной ссылкой, также данную ссылку он сможет опубликовать в своей социальной сети. При переходе по такой ссылке пользователь попадет на страницу с исходным текстом, а браузер будет прокручен к выделенному тексту. Данная возможность включается и отключается в админпанели в настройках скрипта.
q Добавлена возможность включать или отключать в настройках скрипта область действия авторизационных куков и сессий пользователей. Вы можете включить, чтобы авторизационные данные распространялись на домен и все поддомены, что полезно при создании несколько отдельных сайтов с единой системой регистрации и авторизации. Либо вы можете установить, чтобы данные распространялись только на домен где установлен скрипт, что является полезным, если на домене и поддоменах вы создаете полностью независимые сайты.
q Добавлена возможность скачивать некоторые типы файлов, загруженных на сервер через DLE, непосредственно при просмотре сайта с мобильного телефона или смартфона. Например, добавлена поддержка скачивания документов в формате PDF и Word, а также добавлена поддержка скачивания программ для системы Android в формате .apk.
q Для шаблона вывода результатов поиска (searchresult.tpl) добавлено использование новых тегов: {image-x} который выводит URL картинки, находящийся в тексте новости, где "x" это номер картинки в новости, например, {image-1} выведет URL первой картинки в новости. Добавлено использование тегов [image-x] текст [/image-x], которые выводят указанный в них текст, только если картинка с номером "x" присутствует в новости. А также добавлен новый тег {result-text limit="x"}, который выводит текст найденной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного "x" количества символов.
q Добавлена поддержка тегов [hidе]текст[/hidе] для использования в персональных сообщениях на сайте.
q В админпанели, в разделе редактирования пользователей добавлена возможность устанавливать количество пользователей выводимых на страницу при поиске по различным параметрам. Данная опция будет полезна, тем администраторам, которым необходимо выполнить массовые действия над большим количеством пользователей, например, удалить большое количество пользователей.
q В админпанели, в разделе управления картинками, добавлена возможность загружать изображения с компьютера на сервер.
q Для тега пользовательского вывода публикаций {custom} добавлена поддержка атрибута fixed="yes". Данный атрибут позволяет задавать, учитывать ли при выводе публикаций, то что новости были зафиксированы или нет. Например, тег {custom category="1" aviable="global" from="0" limit="10" fixed="yes"}, выведет новости на сайте поместив в самое начало именно зафиксированные новости из указанной категории. А тег {custom category="1" aviable="global" from="0" limit="10" order="date"} выведет отсортированные по дате, при этом не будет учитываться зафиксирована новость или нет.
q Добавлена возможность использования в шаблонах одновременно тегов {title limit="х"} и {title}, {short-story limit="x"} и {short-story} а также тегов {full-story limit="x"} и {full-story}
q BB редактор, используемый на сайте для добавления новостей и для комментариев, полностью переведен на использование шаблонов и стилей CSS шаблонов. Тем самым у веб-мастеров появилась возможность не только менять картинки кнопок редактора, но и полностью кардинально менять его внеший вид по своему усмотрению.
q Внесены изменения в алгоритмы работы фильтра слов. Обработка входящего текста фильтром производится в самом начале, до его обработки парсером ББ тегов. Тем самым расширяются возможности защиты от возможного спама без блокирования возможностей скрипта. Например, при внесении в фильтр таких стоп слов как "http://" или ".ru", больше не будет также блокироваться работа стандартных смайлов используемых в комментариях или новостях.
q Улучшена система поиска пользователей в админпанели в разделе редактирования пользователей. Добавлена возможность поиска пользователей по неполной части логина или e-mail адреса. Например, задав в поиске по e-mail адрес @mail.ru вы можете найти всех пользователей, которые использовали при регистрации почтовый ящик сервера mail.ru и т.д.
q Для шаблонов main.tpl и вывода полных новостей fullstory.tpl добавлены новые теги: [news=1,2,3] текст [/news], которые выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей. Также был добавлен противоположный тег [not-news=1,2,3] текст [/not-news], который выводит текст на любых других страницах кроме просмотра указанных в теге новостей. Тем самым, благодаря данной возможности вы можете настраивать оформление страниц своего сайта для каждой новости персонально.
q Для шаблонов main.tpl и вывода кратких новостей shortstory.tpl добавлены новые теги: [tags=тег1,тег2,тег3] текст [/tags], которые выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов. Также был добавлен противоположный тег [not-tags=тег1,тег2,тег3] текст [/not-tags], который выводит текст на любых других страницах кроме указанных в теге.
q Улучшена система цитирования комментариев на сайте. В случае если посетитель не выделяет текст комментария, а просто нажимает на кнопку цитирования, то в поле вставляется не просто логин пользователя, которому принадлежит комментарий, а полностью цитата его комментария, с сохранением форматирования данного комментария.
q Добавлено автоматическое уведомление поисковых систем об обновлении карты сайта при ее автоматическом обновлении с использованием файла крона.
q Добавлено раскладывание загружаемых файлов (не картинок) на сервер по папкам месяцам. Для этого, при загрузке файлов, в папке uploads/files/ создаются каждый месяц подпапки в формате "год-месяц", куда помещаются загруженные файлы. Тем самым файлы более не накапливаются в одной папке, что делает более удобным поиск нужного файла на сервере при необходимости и снижает нагрузку на файловую систему при большом количестве загружаемых файлов.
q Добавлена возможность для администраторов сайта при загрузке файлов по FTP на сервер в папку uploads/files/, создавать в ней внутренние подпапки, и загружать в них файлы по FTP. Ранее скрипт поддерживал загрузку файлов только непосредственно в саму папку uploads/files/.
q Для шаблона main.tpl добавлены новые шаблонные теги [related-news] {related-news} [/related-news], которые позволяют выводить блок похожих новостей при просмотре полной новости. Данные теги будут полезны для сайтов, которые хотят выводить похожие новости за пределами шаблона вывода полной новости (fullstory.tpl), например в боковых колонках на сайте.
q В админпанели, в разделе управления голосованиями на сайте, добавлена возможность установки для голосования групп пользователей, которым показывать данное голосование. Тем самым вы можете создавать на сайте различные опросы для различных групп пользователей.
q Добавлена поддержка сервиса Gravatar, для использование аватаров пользователями на сайте. Тем самым ваши пользователи могут не только загружать на ваш сервер свои аватары, но и использовать собственные с сервиса Gravatar. Также вы можете просто запретить загрузку аватаров на сервер, и оставить возможность только использования сервиса Gravatar для показа аватаров пользователей.
q В админпанели скрипта в разделе управления настройками категорий, добавлена возможность указывать файлы шаблонов для краткой и полной новости, расположенные в подпапках вашего шаблона. Например, вы можете указать myfolder/test и тогда будет для категории загружаться шаблон по адресу /templates/ ваш шаблон /myfolder/test.tpl.
q Для шаблона вывода полной новости (fullstory.tpl) добавлен новый тег [pages] текст [/pages], который выводит указанный текст в тегах, если новость разбита на несколько страниц при помощи тега {PАGEBREAK} и убирает текст в нем, если новость состоит из одной страницы. Данный тег крайне полезен если вебмастера, при оформлении шаблона, хотят разместить навигацию по страницам в специально оформленных блоках или добавить необходимые дополнительные стили.
q Для тега пользовательского вывода публикаций {custom ...} добавлен новый параметр author="x", который выводит новости, фильтруя их по автору новости, где X это логин автора. Например, тег {custom author="admin" limit="5"} выведет 5 новостей автора с логином "admin".
q Для тега пользовательского вывода публикаций {custom ...} добавлен новый параметр days="x", который выводит новости, используя временной период, где x это количество дней за которые выводить публикации. Например, тег {custom days="2" limit="5"} выведет 5 новостей за 2 последних дня.
q Добавлена возможность, для дополнительных полей новостей с типом "список", устанавливать опцию "Использовать значения полей как перекрестные гиперссылки". Тем самым расширяются возможности по внутренней перелинковке публикаций на сайте.
q При воспроизведении видео с сервиса Youtube в стандартном плеере, добавлен показ превью картинки видео, непосредственно с сервиса Youtube.
q Добавлена возможность самостоятельно переключать посетителем качество видеороликов с сервиса Youtube непосредственно при их просмотре на сайте.
q При удалении новостей найденных в режиме поиска похожих новостей в админпанели, добавлено предварительное уведомление о том, что новость будет удалена безвозвратно, и пользователю необходимо будет подтвердить данное действие. Также добавлена возможность отправки уведомления автору данной новости, с сообщением о причинах удаления данной новости.
q Для редактора шаблонов, в админпанели скрипта, добавлена новая функция автоматического форматирования выделенного кода. Данная функция позволяет отформатировать HTML или CSS код из сжатого вида, в более удобно читаемый код.
q Для шаблона вывода полной новости (fullstory.tpl) добавлено использование новых тегов: {fullimage-x} который выводит URL картинки, находящийся в тексте полной новости, где "x" это номер картинки в новости, например, {fullimage-1} выведет URL первой картинки, находящийся в полной новости. Добавлено использование тегов [fullimage-x] текст [/fullimage-x], которые выводят указанный в них текст, только если картинка с номером "x" присутствует в полной новости.
q Внесены изменения в систему очистки кеша скрипта. В случае если в настройках скрипта включено кеширование Memcache, а сторонние модули не используют настройки кеширования и сохраняют кеш в файлах, то DLE также будет очищать кеш файлы, созданные сторонними модулями при необходимости очистки кеша.
q Добавлена полная поддержка браузера IE10.
q До актуальных версий были обновлены: фреймворк jQuery, WISYWIG редакторы TinyMCE и LiveEditor.
q Исправлена проблема, при которой была возможность регистрировать на сайте визуально невидимые логины.
q Исправлена проблема, при которой происходило некорректное удаление дополнительных полей в админпанели скрипта.
q Исправлена проблема, связанная с некорректной работой тега [code] при редактировании новости в визуальном редакторе TinyMCE.
q Исправлена проблема, при которой в некоторых случаях происходило "зависание" при массовой загрузке картинок и других файлов, и необходимо было закрывать окно загрузки и открывать его повторно.
q Исправлена проблема, при которой невозможно было использовать картинки в персональных сообщениях при использовании WYSIWYG редактора, несмотря на то что использование изображений было разрешено в настройках группы.
q Исправлена проблема, при которой пользователи которым разрешено управлять статическими страницами в админпанели скрипта (в том числе администраторы), не могли управлять загруженными для данной страницы файлами и картинками, если страница была создана другим пользователем на сайте.
q Исправлена проблема, связанная с редактированием информации о категориях при использовании PHP линейки 5.4.x
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.6:

q Полностью переработан тег пользовательского вывода новостей {custom}, помимо изменения алгоритмов его работы для него было добавлено несколько новых возможностей.
q В админпанели скрипта, в разделе управления категориями, добавлена новая удобная система установки порядка сортировки категорий, а также уровней вложенности категорий. Теперь для того чтобы установить новый порядок сортировки, достаточно будет перенести нужные категории мышкой в необходимые позиции и сохранить порядок сортировки. Данная новая система позволяет намного удобнее организовывать большие списки категорий.
q Добавлена возможность подключать файлы шаблонов .tpl, находящихся в подпапках вашего шаблона. Например, при использовании тега {include file="test/my_block.tpl"} будет подключен файл шаблона находящийся в папке: /templates/ваш шаблон/test/my_block.tpl. Тем самым для шаблонов, содержащих сложную структуру и большое подключение файлов шаблонов, можно будет организовать более удобную и читабельную структуру.
q Для всех шаблонов, где используется вывод дополнительных полей для новостей, добавлен новый тег [xfvalue_X limit="X2"], где X это имя дополнительного поля, который выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым с использованием данного тега вы можете делать различное оформление для различных категорий или разделов сайта при выводе информации из дополнительных полей. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test.
q Добавлен вывод даты отправки жалоб в модуле управления жалобами в админпанели скрипта.
q В настройки скрипта добавлена возможность устанавливать ограничение на вес загружаемой картинки с аватаром в профилях пользователей. Ранее данное ограничение было жестко установлено в скрипте размером в 100 кб. Теперь администраторы сайта могут управлять данным параметром в настройках скрипта в админпанели.
q Добавлена возможность включать или отключать поддержку статуса "Онлайн" для пользователей на сайте. В случае отключения данной возможности в настройках скрипта, если вы не планируете использовать на сайте данную возможность, вы можете экономить ресурсы сервера, т.к. обновление данных профилей пользователей будет происходить намного реже.
q В настройки скрипта добавлена возможность указать, по какой стороне проверять и уменьшать оригинальное изображение при его загрузке на сервер, в случае если заданы лимиты на размеры оригинального изображения в настройках скрипта. Вы можете указать уменьшение по наибольшей стороне, либо по ширине, либо по высоте.
q В настройки скрипта добавлена возможность задавать отдельно заголовок для отправляемых писем с сайта, который будет автоматически к письму. Ранее автоматически добавлялось установленное в настройках название сайта, теперь вы можете задать для писем отдельный свой заголовок, который будет использоваться только для отправляемых писем.
q В настройки скрипта в админпанели, добавлена возможность указывать количество новостей, которое будет выводиться в блоке вывода популярных публикаций на сайте.
q В настройки скрипта в админпанели, добавлена возможность указывать количество выводимых самых популярных ключевых слов из облака тегов, которые выводятся блоке облака тегов на сайте.
q Для рекламных материалов, добавляемых в админпанели скрипта, добавлена поддержка новых шаблонных тегов: [banner_x] текст [/banner_x], где X это имя баннера, которые выводят текст заключенных в них, если указанный баннер выводится на странице сайта. Данный тег будет очень полезен, если часть форматирования при выводе баннера необходимо оформить именно в шаблоне, а не непосредственно в поле написания рекламного кода в админпанели скрипта.
q Добавлена поддержка одиночных кавычек в ключевых словах для модуля "Облако тегов".
q Увеличена скорость работы сайта и снижена нагрузка на базу данных, при включенном кешировании сайта в настройках скрипта, если страницы просматривает неавторизованный пользователь. В случае если не требуется получения данных из базы данных MySQL, то соединение с MySQL производиться не будет.
q При создании карты сайта для поисковых систем в админпанели скрипта, добавлено исключение публикаций и статических страниц из карты сайта, если для них была запрещена индексация поисковыми системами.
q Добавлен запрет на регистрацию на сайте, если пользователь уже авторизован на сайте.
q В настройки скрипта добавлена возможность включать или отключать запрет на регистрацию на сайте с одного IP. Если включен данный запрет, то в случае, если IP посетителя использовался для авторизации под другим зарегистрированным аккаунтом, то регистрация для него будет запрещена.
q Полностью переработан вывод результатов голосований на сайте и опросов в новостях. Вывод результатов полностью переведен на использования CSS шаблона, в результате чего каждый сайт может настраивать вид результатов по своему усмотрению.
q Из вывода модуля календаря на сайте, убрано избыточное и устаревшее HTML форматирование, например, убраны теги center. Тем самым все визуальное оформление делается целиком в CSS шаблона.
q Настройки скрипта: "Расширение файлов, допустимых к загрузке", "Максимальный размер файла допустимый к загрузке на сервер", "Максимальная скорость скачивания" были перенесены из общих настроек скрипта в настройки групп. Тем самым вы можете гибко настраивать данные параметры для различных групп пользователей на вашем сайте.
q Для шаблонов вывода краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлен новый тег {title limit="x"} который выводит урезанный до X количества символов, заголовок новости. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова.
q Добавлено автоматическое обновление количества голосов непосредственно при выставлении рейтинга публикации с использованием технологии AJAX.
q Добавлена нативная поддержка HTML5 видео тега <video>, при использовании данного тега при вставке видео, в случае если формат видео не поддерживается браузером, то для него будет использован флеш или silverlight плагин, если это возможно для данного формата файла. Тем самым возможно воспроизведение на абсолютно всех типах браузеров (включая мобильные устройства и планшеты) mp4 файлов, сжатых кодеком h.264, и опубликованных в новости с использованием HTML5 тега <video>.
q В настройки групп добавлена возможность включения или отключения каптчи для формы обратной связи. Тем самым вы можете гибко настраивать какой группе разрешена отправка E-mail сообщений без ввода каптчи.
q В настройки групп добавлена возможность включения или отключения системы Вопрос - Ответ для формы обратной связи. Данная возможность используется для дополнительной защиты от спам ботов формы отправки E-mail сообщений другим пользователям на сайте. Данная система может быть включена как совместно с каптчей, так и без нее.
q В настройки групп добавлена возможность включения или отключения системы Вопрос - Ответ при отправке пользователем персонального сообщения на сайте. Данная возможность используется для защиты от спам ботов в персональных сообщениях.
q Для редактора шаблонов в админпанели скрипта, добавлена возможность поиска по шаблону при его редактировании. Что облегчает поиск нужного элемента в больших файлах шаблонов.
q Добавлена возможность поиска по сайту с использованием специальных символов, таких как двойные и одинарные кавычки, восклицательные знаки, знаки вопросов и т.д.
q В настройки проигрывателей в админпанели, добавлена возможность указания отдельных настроек для ширины аудиоплеера по умолчанию. Ранее настройки ширины для аудиоплеера были равны ширине настроек видеоплеера.
q Дополнены механизмы контроля неверных ЧПУ. Исключено появление дублей страниц по адресам site.ru/page,1,id-post.html и site.ru/id-post.html, если новость разбита на несколько страниц. Если ссылка ведет на неверный номер страницы публикации, то будет осуществляться 301 редирект на первоначальный адрес публикации. Если для публикации комментарии разбиты на несколько страниц, то исключено дублирование первой страницы site.ru/page,1,1,id-post.html будет использоваться всегда site.ru/id-post.html, а также при обращении к несуществующей страницы с комментариями, производится автоматический 301 редирект на первую страницу.
q В шаблоны E-Mail сообщений, для шаблона письма, отправляемого при регистрации пользователю, добавлена поддержка тега {%email%}, который выводит E-Mail адрес, регистрирующегося пользователя. Данный тег будет полезен сайтам, которые используют в настройках скрипта E-mail адрес, а не логин пользователя. Также при восстановлении пароля на сайте, пользователю отправляются новые данные для авторизации также с учетом настроек скрипта, в зависимости от того производится авторизация по логину или по E-mail.
q Из шаблона полной новости (fullstory.tpl) убрана поддержка тега [category=x] текст [/category]. Вместо него были добавлены более функциональные теги: [catlist=1,2....] текст [/catlist] - выводит текст в теге, если новость принадлежит указанным категориям, [not-catlist=1,2....] текст [/not-catlist] - выводит текст в теге, если новость не принадлежит указанным категориям.
q Добавлена возможность быстрого редактирования публикаций, с использованием технологии AJAX, для новостей, опубликованных на сайте с использованием тега пользовательского вывода {custom}.
q Добавлена поддержка линейки PHP 5.4.x. для сайтов использующих кодировку windows-1251. Для сайтов в кодировке UTF-8 поддержка данной линейки PHP была ранее, начиная с версии 9.6.
q Добавлены новые механизмы работы с сессиями, которые позволяют управлять сессиями, как с домена, так и с поддомена, позволяя тем самым логинится и разлогиниваться c любого поддомена. Также независимо от настроек сервера, устанавливается безопасный режим для работы с куками сессии, что делает недоступным идентификатор сессии через javascript и соответственно невозможным перехватить сессию при помощи XSS атак.
q Добавлена поддержка запуска скрипта крона cron.php с использованием консольных команд PHP, и передачей скрипту соответственно аргументов через консоль. Например, для запуска антивируса по крону, вы можете использовать консольную команду php -f cron.php antivirus. При этом конечно не следует забывать про указание правильных путей как к PHP интерпретатору, так и к самому скрипту.
q В админпанели скрипта добавлена нумерация строк при редактировании файлов шаблона в редакторе шаблонов. А также было исправлено несколько ошибок связанным с редактированием определенных форматирований шаблона.
q По пожеланиям многих пользователей был возвращен визуальный редактор TinyMCE. При этом новый визуальный редактор, появившийся начиная с версии 9.6 был также оставлен. Теперь администратор сайта в настройках скрипта может сам выбрать, какой редактор он хочет использовать. На выбор предлагается три редактора: Стандартный (BBCODES), LiveEditor WYSIWYG, TinyMCE WYSIWYG.
q Для LiveEditor WYSIWYG редактора добавлена поддержка вставки контента из буфера обмена как простой текст, при этом из вставляемого текста полностью удаляется форматирование и остаются только переносы строк. Также добавлен режим полноэкранного редактирования текста в редакторе, что делает удобным редактирование больших текстов.
q Для LiveEditor WYSIWYG редактора в админпанели скрипта добавлена возможность вставки HTML 5 видео. Для ввода видео вы можете использовать три различных формата HTML 5 видео (MP4, WebM, Ogg) для поддержки воспроизведения во всех браузерах.
q Улучшена система очистки кода от избыточного форматирования и кода в визуальном редакторе LiveEditor.
q Исправлено несколько небольших проблем в визуальном редакторе LiveEditor, связанных с форматированием текста.
q Исправлена проблема, при которой не очищался сразу автоматически кеш комментариев при редактировании профиля пользователя в админпанели скрипта.
q Исправлена проблема, при которой невозможно было редактировать дополнительные поля при быстром редактировании, если новость была опубликована в несколько категорий для сайтов в кодировке windows-1251
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.5:

q Добавлен принципиально новый загрузчи изображений и различных файлов на сервер. Новый загрузчик имеет большое количество принципиальных отличий от старого, поэтому остановимся на его возможностях подробнее:

- Новый загрузчик файлов использует всплывающие окна, основанные на JQuery UI, благодаря чему он полностью интегрирован в дизайн страниц и его внешний вид полностью настраивается в CSS вашего шаблона.

- Загрузка файлов происходит полностью с использованием технологии AJAX, т.е. без перезагрузки страниц, загрузка файлов на сервер происходит в фоновом режиме.

- Новый загрузчик написан с поддержкой стандарта HTML5 соответственно браузеры, полноценно поддерживающие данный стандарт имеют ряд преимуществ: возможность выбора нескольких файлов для загрузки одновременно, а также поддержка технологии Drag and Drop, т.е. вы можете просто перенести в Windows выбранные файлы мышкой в область загрузки, и их загрузка начнется автоматически. Полноценной поддержкой данной технологии на текущий момент обладают только два браузера, это Firefox и Chrome.

- Также присутствует существовавший ранее флеш загрузчик, предназначенный для массовой одновременной загрузки файлов во всех браузерах. При этом была переписана дружелюбность данного загрузчика к пользователю и в случае ошибок загрузки файла, вместо кодов ошибок он выводит полноценные и понятные сообщения об ошибках и причинах ошибки загрузки.

- После загрузки изображений на сервер, все загруженные изображения отображаются в виде превью загруженных картинок, и вы можете видеть, какую картинку вы выбираете и вставляете визуально.

- Перед тем как вставить загруженное изображение в новость, пользователь может в удобном виде задать описание изображения, выравнивание по которому вставлять изображение, а также как вставить изображение, в виде оригинала или уменьшенной копии.
q Добавлен новый WYSIWYG редактор для написания новостей и статических страниц. Отличительными особенностями нового редактора является следующее:

- Более меньший вес редактора и как следствие более быстрая загрузка редактора в браузер.

- Более простой и интуитивно понятный интерфейс редактора, что облегчает пользование редактором неподготовленному пользователю

- Улучшенная и удобная вставка изображений, позволяющая добавлять различные эффекты к изображению без знаний HTML.

- Встроенная поддержка сервиса "Google Шрифты" позволяющая использовать на сайте различные красивые шрифты.

- Встроенная поддержка сервиса "Youtube", позволяющая искать и вставлять видеоролики непосредственно в редакторе не заходя на сайт Youtube

- Подсветка редактируемого исходного кода HTML
q Добавлена частичная безопасная поддержка HTML тегов iframe. Поддержка была реализована для того чтобы можно было вставлять некоторые данные с сервисов, которые не поддерживают других API средств кроме iframe, например вставка видео с сервиса вконтакте, теперь видео можно вставлять в новость путем простого копирования кода в редактор. Т.к. тег iframe не является безопасным тегом. То его работа ограничивается только при работе с ограниченным списком разрешенных безопасных доменов. На данный момент поддерживаются домены http://vkontakte.ru/, http://www.youtube/, http://maps.google.com/.
q Добавлена возможность загружать изображения и прочие файлы для новостей при "быстром" редактировании новостей на сайте.
q При добавлении и редактировании новостей в админпанели скрипта добавлена возможность указывать для поисковых систем разрешено или запрещено им индексировать страницу с данной новостью. Возможность выбора опции индексирования есть только у администраторов и главных редакторов сайта.
q Добавлена возможность для статических страниц указывать разрешено или запрещено поисковым системам индексировать данную статическую страницу.
q Полностью переписаны алгоритмы работы модуля показа похожих публикаций при просмотре полной новости. Благодаря этому удалось добиться существенного прироста скорости работы данного модуля и существенно снизить нагрузку на сервер от работы данного модуля. Для того чтобы это обеспечить новый алгоритм осуществляет полнотекстовый поиск по публикациям только один раз, во время первого просмотра новости на сайте, после чего данные о найденных публикациях сохраняются в базе данных, и дальнейшем при показе блока на сайте используются очень быстрые запросы к базе данных на выборку по числовым ID.
q В админпанели скрипта в раздел перестроения публикаций добавлен раздел перестроения кеша похожих новостей. Тем самым если вы хотите сбросить кеш у старых новостей, чтобы в них появились ссылки на похожие новости, добавленные позднее, вы всегда можете в любое время сбросить кеш и похожие новости будут найдены повторно.
q Существенно увеличена скорость работы рейтинга новостей для сайтов, с большим объемом новостей, рейтинг был помещен в отдельную более легкую таблицу, что существенно увеличивает скорость работы базы данных MySQL при выставлении рейтинга новости пользователем.
q Существенно увеличена скорость работы счетчика просмотров новостей для сайтов, с большим объемом новостей, как при его включенном кешировании, так и при отключении кеширования счетчика.
q Существенно увеличена скорость работы пересчета статистики количества новостей и комментариев у пользователей в админпанели в мастере оптимизации, устаревшие методы пересчета, были заменены на более быстрые MySQL запросы.
q В настройки групп добавлена возможность устанавливать для группы пользователей, у которой установлен показ каптчи и контрольного вопроса, количество новостей, при достижении которого каптча и контрольный вопрос не будет показываться. Тем самым вы можете установить, чтобы данные средства противодействия спамерам, отключались для ваших активных пользователей сайта, которые спамерами не являются.
q В настройки групп добавлена возможность устанавливать для группы пользователей, у которой установлен показ каптчи и контрольного вопроса, количество комментариев, при достижении которого каптча и контрольный вопрос не будет показываться. Тем самым данные средства защиты не будут постоянно мешать вашим активным комментаторам, которые спамерами не являются.
q Добавлена возможность просмотра на сайте, является ли пользователь в данный момент онлайн или оффлайн на сайте. Для этого в шаблоны профиля пользователя, карточки пользователя и комментарии добавлены теги: [online] текст [/online] - выводят текст если пользователь онлайн, [offline] текст [/offline] - выводят текст если пользователь оффлайн. Статус активности пользователя определяется интервалом в 20 минут, если в течении 20 минут не было никакой активности и посещений сайта от данного пользователя, то его статус автоматически становится оффлайн.
q Для шаблонов комментариев (comments.tpl) добавлен новый тег {lastdate} который выводит дату последнего посещения сайта пользователя, оставившего данный комментарий.
q В админпанели скрипта, в разделе управлениями жалоб, добавлена возможность отправлять персональные сообщения авторам жалобы, если они зарегистрированы на сайте.
q Для быстрого редактирования новостей на сайте добавлена возможность одновременного редактирование краткой и полной новости, независимо от расположения на сайте, где запускается редактирование.
q Добавлены новые механизмы в режим контроля ЧПУ, позволяющие не только контролировать неверные URL, но и смену типа ЧПУ. При смене типа ЧПУ все ссылки на старые ЧПУ будут автоматически перенаправляться на новый тип ЧПУ. Также при этом контролируется включение и отключение ЧПУ. Тем самым вы можете безболезненно сменить тип ЧПУ, включить его, на уже проиндексированном поисковиками сайте. Поисковые системы будут получать автоматически 301 редирект, на новые адреса новостей, что способствует более быстрой и корректной переиндексации сайта поисковыми системами.
q При восстановлении бекапа базы данных в админпанели скрипта добавлен контроль версии скрипта, при помощи которой данный бекап создавался, и в случае не соответствия версии БД с версией скрипта, восстановление бэкапа будет приостановлено. Данное нововведение позволяет избежать наиболее частых ошибок, совершаемых администратором сайта, а именно восстановление БД от старых версий скрипта, что приводит к нарушению работы скрипта.
q Для шаблонов вывода краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлены новые теги: {image-x}, который выводит URL картинок находящихся в новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в новости, [image-x] текст [/image-x] которые выводят текст, указанный в них только в случае если картинка с номером X присутствует в новости.
q Для шаблона вывода краткой новости (shortstory.tpl) добавлен новый тег {short-story limit="x"} который выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым с использованием данного тега вы можете делать различное оформление для различных категорий или разделов сайта.
q Для шаблона вывода полной новости (fullstory.tpl) добавлен новый тег {full-story limit="x"} который выводит только текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова.
q Для RSS информеров в шаблонах добавлена поддержка тегов: {image-x} которые выводят URL картинок находящихся в тексте новости из RSS потока, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в новости. А также добавлено использование тегов [image-x] текст [/image-x] которые выводят текст указанный в них только в случае если картинка с номером X присутствует в новости из RSS потока.
q Добавлены новые глобальные шаблонные теги, которые вы можете использовать в любых файлах шаблонов: [page-count=1,2,3] текст [/page-count], данный тег выводит текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации. Данный тег позволит очень гибко настроить вывод той или иной информации, на определенной странице и полезен для информационных блоков и рекламы. Вы можете использовать данный тег совместно с другими, опеределяющими разделы сайта и категории. Например, комбинация тегов [aviable=cat][category=1][page-count=1] текст [/page-count][/category][/aviable] выведут текст, только если пользователь просматривает первую страницу категории с id1, и при этом просматривает именно краткие новости, и при переходе на другую страницу в этой категории, данного текста он уже не увидит. Также был добавлен противоположный тег [not-page-count=1,2,3] текст [/not-page-count], который выводит новости на любых номерах страниц кроме указанных в теге.
q Внесены изменения при показе рекламных материалов, добавленных в админпанели скрипта, и которым установлена опция "Показывать только на главной (несквозной баннер)". Данные рекламные материалы будут показываться пользователю также если он на главной странице проходил процедуру авторизации на главной странице, т.е. будет показываться всегда, при любых действиях пользователя, главное чтобы он при этом находился на главной странице.
q В админпанели скрипта в разделе управления рекламными материалами, добавлена новая опция: "Выводить только на первой странице раздела или категории". При включении данной опции код рекламы будет показан только на первой странице, и если раздел состоит из нескольких страниц, то на последующих страницах код показан не будет. Например, вы назначили код только при показе определенной категории и включили данную опцию. То при переходе в данную категории, посетитель увидит ваш код, только на первой странице данной категории, и на последующих страницах, его уже не будет.
q Для шаблонов краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлены новые теги: [rating] текст [/rating], которые выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости. Данные теги делают более гибким оформление в шаблоне, когда при отключении рейтинга нужно убирать и количество голосов.
q В админпанели, в разделе управления пользователями, добавлена более удобная и компактная панель для постраничной навигации, что делает более удобным поиск и редактирование пользователей в админпанели скрипта.
q Для персональных сообщений на сайте добавлена возможность отслеживать отправителем, было ли прочитано письмо получателем или еще нет. Для этого при отправке письма отправитель должен сохранить копию сообщения в папке отправленных, при этом в данной папке письмо будет отображаться как непрочитанное до тех пор, пока получатель на сайте не прочитает его. Как только он это сделает, письмо в папке "Отправленное" у отправителя получит статус прочитанного.
q Добавлена постраничная навигация в разделе персональных сообщений на сайте. Что делает более удобным поиск и чтение, а также управление персональными сообщениями на сайте.
q Внесены небольшие изменения в показ списка персональных сообщений на сайте. Непрочитанные персональные сообщения всегда идут первыми в списке сообщений. Что при большом количестве сообщений позволяет пользователям всегда увидеть сообщения, которые ими еще не были прочитанными.
q Для персональных сообщений на сайте добавлена возможность выводить визуальную графическую шкалу наполненности ящика пользователя персональными сообщениями. В случае если на ящик пользователя установлены лимиты на количество персональных сообщений, он может визуально видеть, сколько ему еще осталось до лимита. Отображение является польностью настраиваемой в шаблонах и CSS, и может принимать какой угодно визуальный вид. Для этого в шаблон pm.tpl добавлены следующие теги: {pm-limit} - выводит максимальное количество сообщений, который может хранить пользователь, {proc-pm-limit} выводит количество заполненного пространства ящика пользователя в процентах, {pm-progress-bar} выводит шкалу наполненности ящика персональных сообщений.
q В настройки групп добавлена возможность сделать неограниченным максимальное количество персональных сообщений, которое может хранить у себя пользователь.
q Добавлено выполнение массовых действий над персональными сообщениями на сайте, пользователем. Выбранные персональные сообщения можно отметить уже прочитанные, или наоборот снять отметку о прочтении, чтобы можно было визуально их выделить и поднять наиболее важные сообщения, а также выбранные сообщения можно удалить.
q Добавлен контроль незакрытых BB тегов b, i, u, s, в случае если количество открывающих тегов не совпадает с количеством закрывающих тегов, данные теги не обрабатываются, что позволяет избегать распространения действия данных тегов на всю страницу сайта.
q Обновлен редактор шаблонов в админпанели скрипта, устранены некоторые проблемы с форматированием и отображением кода, а также небольшое увеличение производительности редактора.
q Исправлена проблема, при которой скрипт выдавал ошибку БД в админпанели, при попытке установить E-mail уже существующий у другого пользователя, при редактировании личных настроек.
q Исправлена проблема, связанная с некорректной обработкой тега [category=x] [/category] при включенном показе похожих новостей, если похожие новости были найдены из других категорий.
q Исправлена проблема, при которой во время автоматического генерирования метатегов из текста, в них поступали HTML сущности.
q Исправлена проблема, при которой категории, в которые запрещено добавлять новости, но которые разрешены к просмотру, не отображались в разделе поиска по сайту в списке категорий.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.4:

q Добавлена поддержка Memcache для кеширования на сайте. В настройках скрипта, вы можете выбрать какой тип кеширования использовать на сайте. Либо файловый кеш либо Memcache. При включении данной настройки убедитесь, что Memcache включен и поддерживается вашим хостингом. А также уточните данные для подключения к Memcache серверу.
q Улучшена система кеширования на сайте. Добавлено кеширование MySQL запросов для просмотра полных новостей, добавлено кеширование MySQL запросов комментариев к ним, что позволяет еще больше снизить нагрузку на MySQL на посещаемых сайтах. А также улучшены алгоритмы автоматической очистки кеша.
q В админпанели скрипта при добавлении и редактировании новостей, добавлена новая система выбора категорий новости. Данная система специально адаптирована для работы со списками, содержащими большое количество категорий. В данную систему выбора интегрирован поиск нужной категории, для этого достаточно набрать часть имени категории.
q В настройки скрипта добавлена возможность включения вывода новостей на сайте, дата публикации которых еще не наступила. Данная опция будет полезна сайтам публикующие, например анонсы на запланированные мероприятия или например для публикации афиш.
q Для дополнительных полей добавлена возможность устанавливать опцию: "Использовать значение полей как перекрестные гиперссылки". При включении данной опции для дополнительного поля, значение дополнительного поля при выводе в публикациях становится ссылкой на показ всех публикаций содержащих аналогичные значения дополнительных полей. Тем самым данная возможность позволяет группировать новости по значениям этих полей. Например, если ваш сайт это каталог видео фильмов, то вы можете группировать новости по актерам, жанрам и т.д. При этом если значения доп. полей перечислены через запятую, то автоматически для каждого слова будет сформирована отдельная ссылка. Например, вы создали дополнительное поле для жанров видеофильмов, при написании новости в данном дополнительном поле вы можете через запятую перечислить жанры, например, "Комедия, Драма, Исторический" и для каждого из этих слов будет сформирована отдельная ссылка на поиск новостей содержащие данные значения по отдельности.
q Для простого типа поиска по сайту, добавлена опция: "Точное совпадение всех слов", тем самым при нахождении большого количества результатов поиска, пользователь может сузить количество найденных результатов, до наиболее подходящих.
q Добавлена возможность перестроения статических страниц в админпанели скрипта в разделе перестроения новостей.
q Для шаблонов краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлен новый тег: {category-url} который выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки. Тем самым вы можете задавать в шаблонах собственное необходимое оформление, например вы можете сделать кликабельной иконку категории, и т.д.
q Существенно улучшена вставка изображений в новости и комментарии, с использованием BBCODES редактора. При вставке ссылки на изображение вы можете сразу задать описание для картинки, а также в выпадающем меню выбрать необходимое выравнивание изображения на странице.
q Для шаблона вывода результатов поиска (searchresult.tpl) добавлена поддержка тегов [catlist=1,2....] текст [/catlist] которые выводят текст в теге, если новость принадлежит указанным категориям, а также добавлена поддержка тегов [not-catlist=1,2....] текст [/not-catlist] которые выводят текст в теге, если новость не принадлежит указанным категориям.
q В админпанели, в разделе IP утилит, добавлена возможность банить необходимые IP адреса, непосредственно из данного раздела.
q Для статических страниц добавлена возможность устанавливать, публиковать или не публиковать ссылку на данную страницу при создании карты сайта для поисковых систем. Тем самым вы можете отключать необходимые вам страницы из карты сайта.
q При добавлении и редактировании статических страниц, добавлена возможность, автоматически генерировать описание и ключевые слова для метатегов, с использованием технологии AJAX, на основе написанного текста для статической страницы. Тем самым вы можете быстро отредактировать сгенерированные автоматически слова, убрав лишнее, а не набирать их полностью вручную.
q В настройки групп добавлена возможность устанавливать ограничения на количество загружаемых на сервер изображений для одной новости, тем самым вы можете ограничить пользователей, в загрузке изображений на сервер, и избежать излишнего засорения сервера изображениями.
q В настройки групп добавлена возможность устанавливать ограничения на количество загружаемых на сервер файлов (не изображений) для одной новости, тем самым вы можете ограничить пользователей, в загрузке файлов на сервер, и избежать излишнего засорения сервера файлами.
q Добавлена автоматическая очистка значений дополнительных полей в базе данных, если дополнительное поле было удалено в админпанели скрипта. Для того чтобы очистить значения удаленных дополнительных полей, необходимо в админпанели скрипта запустить перестроение публикаций. При перестроении публикаций, если поле было удалено с сайта, то будут из базы данных удаляться и значения данных дополнительных полей.
q Для шаблонов краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлены новые теги: [comments] текст [/comments], которые выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте, а также добавлены теги: [not-comments] текст [/not-comments], которые выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте. Тем самым вы можете гибко настраивать дизайн своего сайта, в отличии от ситуации, например, если у новости нет комментариев, то предлагать пользователю быть первым, а если есть, то выводить количество комментариев.
q В админпанели, в разделе редактирования новостей, добавлена ссылка на просмотр данной новости на сайте. Для того чтобы перейти на просмотр новости, достаточно кликнуть на количество просмотров данной новости.
q Для шаблонов просмотра профиля пользователя и комментариев (userinfo.tpl и comments.tpl) добавлены новые теги: [xfnotgiven_X]...[/xfnotgiven_X], которые выводят текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя. Тем самым оформление дополнительных полей для пользователей становится еще более гибким, и вы можете комбинировать различное оформление в зависимости от того, было ли поле написано или нет.
q Для шаблонов просмотра профиля пользователя, комментариев а также карточки пользователя (userinfo.tpl, comments.tpl и profile_popup.tpl) добавлены новые теги: [fullname] {fullname} [/fullname] - которые выводят текст заключенный в них только если полное имя пользователя задано, [not-fullname] текст [/not-fullname] - которые выводят текст, заданный в них только если полное имя пользователя не задано. [icq] {icq} [/icq] - которые выводят текст заключенный в них только если ICQ пользователя задано, [not-icq] текст [/not-icq] - которые выводят текст, заданный в них только если ICQ пользователя не задано. [land] {land} [/land] - которые выводят текст заключенный в них только если местожительство пользователя было им задано, [not-land] текст [/not-land] - которые выводят текст, заданный в них только если местожительство пользователя не было им указано. [news-num] {news-num} [/news-num] - которые выводят текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте, [not-news-num] текст [/not-news-num] - которые выводят текст заключенных в них если у данного пользователя нет новостей на сайте. [comm-num] {comm-num} [/comm-num] - которые выводят текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте, [not-comm-num] текст [/not-comm-num] - которые выводят текст заключенных в них если у данного пользователя нет комментариев на сайте. Тем самым вы получаете больше возможностей для разнообразной верстки данных шаблонов, в зависимости от данных условий.
q Для шаблона вывода результатов поиска (searchresult.tpl) добавлена поддержка тега {date=формат даты}, предназначенного для вывода даты новости в пользовательском формате.
q Добавлена поддержка вывода дополнительных полей, назначенных для профиля пользователя, при выводе всплывающей карточки пользователя (шаблон profile_popup.tpl). Для вывода дополнительных полей, используются аналогичные теги, как и для шаблонов комментариев и показа профиля пользователя.
q В настройки групп добавлена возможность ограничивать для различных групп, максимальное количество комментариев, которое им разрешено публиковать на сайте в сутки. Данный лимит также можно отключать.
q Добавлена поддержка национальных символов (в том числе и кирилицы), при автоматическом создании буквенного каталога.
q Для шаблона вывода краткой новости (shortstory.tpl), а также для шаблонов вывода новостей с использованием тега {custom} добавлен новый тег {vote-num}, который выводит количество проголосовавших за публикацию пользователей.
q Добавлено использование шаблонной картинки заглушки /dleimages/no_image.jpg для тегов {image-x} в шаблонах. Данная картинка будет использоваться в том случае, если для данного тега в новости, отсутствует подходящее для него изображение.
q Для шаблонов вывода популярных новостей, похожих новостей и пользовательского вывода новостей при помощи тега custom, добавлено использование тегов [image-x] текст [/image-x] которые выводят текст указанный в них только в случае если картинка с номером X присутствует в новости.
q Для шаблонов вывода популярных новостей и похожих новостей (topnews.tpl и relatednews.tpl) добавлено использование тегов {category} и {link-category} которые выводят списки категорий, которым принадлежат публикации, а также ссылки на данные категории.
q В настройки скрипта в разделе настроек E-mail добавлена настройка для определения типа соединения и авторизации (SMTP HELO) на SMTP сервере. Вы можете выбрать, что отправлять серверу HELO или EHLO. Ранее всегда использовалась стандартная отправка HELO, однако некоторые почтовые серверы требуют использования именно EHLO.
q При использовании обратной связи на сайте добавлено использование тега {%group%}, который используется в шаблоне E-mail сообщений. Данный тег позволяет отправлять в письмах с сайта группу, в которой находится на сайте, отправитель сообщения.
q Для шаблонов популярных новостей и похожих новостей (topnews.tpl, relatednews.tpl) добавлена поддержка дополнительных полей публикаций. Для вывода дополнительных полей используются и поддерживаются все аналогичные теги для доп. полей, которые используются при выводе кратких и полных публикаций.
q Добавлена подсветка текста, опубликованного с использованием тега [cоde]. Подсветка кода поддерживает PHP, javascript, HTML, CSS, SQL.
q Добавлена новая система редактирования профиля пользователей в админпанели и на сайте для администраторов. Редактирование переведено на использование Jquery UI, что позволяет избавится от всплывающих окон браузера и интегрировать редактирование пользователя непосредственно в дизайн сайта.
q Добавлено GZIP сжатие и кеширование сжатых файлов для WYSIWYG редактора. Тем самым существенно ускорена загрузка редактора в браузер пользователя, если он включен и используется в настройках скрипта. А также WYSIWYG был обновлен до актуальной версии.
q Шаблоны для версий для печати, такие как print.tpl и static_print.tpl переведены из общей папки шаблонов, непосредственно в шаблоны, тем самым для каждого шаблона своего сайта вы можете настраивать индивидуальную версию для печати в зависимости от используемого пользователем шаблона. Также данные файлы шаблонов могут редактироваться редактором шаблонов в админпанели скрипта.
q Обновлен редактор шаблонов в админпанели, существенно улучшена скорость работы редактора при редактировании текста, исправлены некоторые ошибки в подсветке и фокусировании текста при редактировании.
q Добавлен контроль ЧПУ, при использовании ссылок на категории без слеша на конце. Ранее скрипт не обрабатывал эти ссылки, отдавая серверную ошибку 404, новый механизм добавляет обработку этих ссылок скриптом, и в случае отсутствия слеша, происходит 301 редирект на корректную ссылку со слешем на конце URL.
q Добавлена поддержка прозрачности в PNG картинках, при их загрузке на сервер.
q Небольшие изменения при выводе статистики на сайте, направленные на исправление ошибок валидности XHTML страницы.
q Оптимизирована работа JS скриптов, для более корректной работы в браузере Internet Explorer 7.
q Оптимизированы алгоритмы работы поиска, в результате существенно увеличилась скорость работы поиска на больших базах данных.
q Для RSS экспорта новостей в формате "Яндекс новости" внесены изменения под новые технические требования Яндекса, благодаря этому просмотр RSS адресованного для Яндекс новостей, стал доступен для просмотра обычными посетителями с использованием обычных RSS просмотрщиков и браузеров.
q Внесены изменения в алгоритмы работы перестроения публикаций в админпанели скрипта. В случае если в настройках скрипта включено автоматическое уменьшение картинок расположенных на внешний серверах, то скрипт автоматически уменьшает количество обрабатываемых новостей за один проход, тем самым увеличивается вероятность того что скрипт не будет превышать лимитов по времени на время работы на сервере, и перестроение будет проходит успешно.
q В систему логирования действий пользователя в админпанели добавлена расширенная информация об авторизации пользователя в админпанели. Например, вводил ли он логин или пароль вручную или авторизовывался по кукам, если авторизация была по кукам то с какой страницы сайта он пришел в админпанель скрипта.
q Обновлены библиотеки Jquery и Jquery UI до актуальных версий.
q Исправлена проблема, при которой осуществлялся показ новостей в списке похожих новостей из категорий, которые были запрещены для показа определенным группам пользователей в настройках групп.
q Исправлена проблема с контролем URL ЧПУ, при котором проверка не проводилась, если альтернативное имя URL новости было пустым.
q Исправлена проблема, при которой некорректно работал тег {comment-id} в шаблоне комментариев, если в настройке скрипта для комментариев был включен режим AJAX навигации.
q Исправлена проблема, при которой пользователи, которым не разрешено голосовать в опросах новостей, могли в определенных случаях обходить данное ограничение и голосовать в новости

Список изменений относительно версии 9.3:

q В админпанели скрипта добавлен новый раздел учета всех действий пользователей в админпанели скрипта. В данном разделе собираются все действия пользователей, осуществляемых в админпанели скрипта, за последние 30 дней, тем самым администратор сайта может всегда посмотреть, какие действия осуществлял тот или иной пользователь админпанели. Собираемые скриптом данные удалить в скрипте нельзя, они автоматически удаляются скриптом по истечении 30 дней, с момента их осуществления.
q В админпанели скрипта добавлено логирование всех входов в админпанель скрипта от пользователей, имеющих доступ к админпанели. При этом фиксируется время входа в админпанель, логин пользователя и его IP, с которым он входил в админпанель скрипта.
q В админпанели скрипта добавлен новый раздел: "Анализ производительности". В данном разделе производится анализ всех настроек скрипта и настроек групп пользователей, и по результатам анализа выдаются рекомендации по изменению и отключению тех или иных возможностей скрипта. При этом результаты выводятся с подробными описаниями, почему нужно отключить ту или иную возможность, а также результаты выводятся в специальных графически выделенных блоках, определяющих степень нагрузки той или иной возможности. Рекомендации выделенным красным, необходимо выполнять в первую очередь, т.к. позволяют снизить существенно нагрузку на сервер. Рекомендации в желтом блоке указывают на среднюю степень нагрузки. Рекомендации, выделенные зеленым, способны лишь незначительно снизить нагрузку. Тем самым использование данного раздела рекомендуется в первую очередь, тем, кто испытывает проблемы с нагрузкой на сайт, на своем хостинге и хочет попытаться решить проблему "малой кровью", без смены тарифного плана на хостинге и перехода на более мощные ресурсы. Данный раздел будет полезен как новичкам, недавно пользующимся скриптом, так и более опытным пользователям.
q Добавлена новая дополнительная система защиты сайта от спам ботов, основанная на системе Вопрос - Ответ. В админпанели в специальном разделе администратором сайта задается список вопросов и варианты ответа на данные вопросы. При этом данная система может включаться отдельно для регистрации, добавления новостей, добавления комментариев. Для регистрации система включается в настройках скрипта, а для добавления новостей и комментариев включается в настройках групп, и может включаться только для некоторых групп пользователей. Данная система вопроса-ответа является полностью автономной и независимой от каптчи на сайте и может использоваться как совместно с каптчей, так и отдельно. Для вывода системы вопроса и ответа используются шаблонные теги [question] и [/question], которые выводят текст заключенный в данные теги если система вопрос-ответ включена и тег {question} который выводит вопрос для посетителя.
q Добавлена возможность включения в настройках скрипта навигации по страницам комментариев при помощи технологии AJAX без перезагрузки страницы. Например для новости добавлено большое количество комментариев, которые разбиты на несколько страниц, то при включении данной опции, комментарии будут подгружаться на эту же страницу, тем самым снижается нагрузка на сервер, т.к. выполняется только малая часть кода, ответственного только за показ комментариев на сайте. При этом повторно перегрузить просматриваемую страницу комментариев, можно будет нажав на ссылку вывода комментариев, заключенную в теге [com-link] [/com-link] в шаблоне полной новости.
q Добавлена новая система быстрого редактирования новостей на сайте. При быстром редактировании, все поля для редактирования новости открываются в специальном всплывающем окне для редактирования, которое имеет большие удобные размеры, тем самым редактирование текста стало более удобным и не зависит от размеров ваших блоков, где располагаются новости на странице.
q Добавлена возможность при быстром редактировании, редактировать также и дополнительные поля для данной новости, а не только краткую или полную новость. При этом при быстром редактировании, можно редактировать только те дополнительные поля, для которых уже задавалась информация при добавлении новости. Если необходимо изменить или добавить информацию в поле, которое ранее не задавалось, то необходимо переходить в полное редактирование новости.
q Добавлена новая система жалоб пользователей на грамматические ошибки. Посетитель сайта, находясь на странице вашего сайта может выделить любой текст в браузере и нажать Ctrl+Enter и ему будет предложено отправить уведомление о грамматической ошибке в выделенном тексте. При этом пользователь может выделить любой текст на любой странице вашего сайта. Поэтому рекомендуем вам разместить какой либо блок-уведомление в какой либо видимой части вашего сайта, что у посетителей есть возможность отправлять уведомления администрации о грамматических ошибках на сайте. Управление жалобами на грамматические ошибки осуществляется в админпанели в разделе управления жалобами. Само уведомление отправляется с сайта с использованием технологии AJAX без перезагрузки страницы, и не доставляет неудобств пользователям.
q Для шаблонов статических страниц, а также в тексте статических страниц добавлена поддержка тега: [static=имя страницы] текст [/static] который выводит текст заключенный в теги , если посетитель просматривает статическую страницу с указанным именем. А также добавлена поддержка тега: [not-static=имя страницы] текст [/not-static], который выводит текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.
q Для шаблона полной новости (fullstory.tpl) добавлена поддержка тега пользовательского тега {custom category="2,7" template="custom" aviable="global" from="0" limit="10" cache="yes"} предназначенного для вывода новостей из определенных категорий в пользовательском формате. Тем самым вы можете организовать в шаблоне вывод новостей с необходимым вам оформлением, например из этой же категории что и сама новость.
q Добавлена поддержка мультикатегорий в дополнительных полях для новостей. Если разным категориям назначены разные дополнительные поля новостей, то при одновременном их выборе, при добавлении новости, скрипт будет предлагать заполнить все назначенные выбранным категориям дополнительные поля, а не только для первой по списку категории, как было ранее.
q Переработан флеш видеоплеер, в результате которой была оптимизирована загрузка некоторых видеофайлов, а также устранены проблемы, которые в определенных ситуациях могли приводить к зависанию плеера.
q Для тега [mediа=http://...] добавлена поддержка игрового сервиса http://www.gametrailers.com/. Для вставки видео с данного сервиса на своем сайте, используется URL на котором расположен необходимый видеоролик.
q Для карточки профиля пользователя (шаблон profile_popup.tpl) добавлена поддержка тегов [rss] тект [/rss], которые публикуют ссылку в профиле на RSS поток всех новостей пользователя.
q Добавлена возможность редактирования профилей пользователей, непосредственно при редактировании комментариев сайта в админпанели скрипта. Тем самым вы можете забанить пользователя или запретить ему публикацию непосредственно на страницах редактирования комментариев.
q Добавлена возможность блокировать IP пользователя отправившего комментарий, непосредственно при редактировании комментариев сайта в админпанели скрипта.
q При входе администратора в админпанель скрипта, добавлено автоматическое уведомление администратора во всплывающем окне, о поступивших новых жалобах на сайте, с момента его последнего посещения. Что позволяет администратору своевременно реагировать на новые жалобы.
q В настройки видеопроигрывателей на сайте добавлен новый режим качества "Автоматический" воспроизведения видео роликов с сервиса Youtube. При выборе данного режима качества, плеер автоматически выбирает качество видео для каждого пользователя персонально. В зависимости от скорости его интернет соединения и прочих параметров.
q Добавлена проверка заполнения обязательных дополнительных полей для публикаций, еще до отправки данных на сервер. Тем самым если необходимые дополнительные поля были не заполнены пользователем, то остальная написанная им информация не будет потеряна, а пользователю будет показано уведомление о необходимости заполнения всех обязательных полей к публикации.
q Добавлена возможность при авторизации на сайте пользователя устанавливать ему опцию "Не сохранить на данном компьютере". При выборе данной опции во время авторизации, срок жизни его авторизации будет ограничен временем пока открыт браузер. После закрытия браузера, информация о авторизации на сайте автоматически удаляется. Данная опция будет полезна тем кто заходит на сайт с чужого или общественного компьютера.
q Улучшены алгоритмы контроля ЧПУ при проверке адреса URL для просмотра полной новости.
q Добавлена возможность в настройках скрипта задавать метод авторизации пользователей на сайте. Вы можете установить как производить пользователям авторизацию на сайте, с использованием логина и пароля или с использованием E-mail и пароля. Включив например авторизацию с использованием E-mail вы увеличиваете тем самым безопасность по защите данных пользователя от подбора авторизации, т.к. E-mail на сайте не показывается и неизвестен никому кроме самого пользователя.
q При добавлении или редактировании статической страницы в админпанели скрипта, добавлена возможность включения или отключения для данной страницы счетчика просмотров страницы.
q Для WYSIWYG редактора добавлено новое API для проверки орфографии написанного текста. Проверка ведется при помощи сервиса Яндекса, что для русского языка дает более лучшие преимущества, чем сервис от Google. Яндекс имеет гораздо больший словарный запас и производит более корректную проверку, написанного текста.
q В настройки видеопроигрывателя добавлена возможность устанавливать параметры проигрываемого видео по умолчанию. Вы можете установить следующие параметры: Оригинальный размер видео, увеличение видео по размеру проигрывателя с сохранением пропорций видео, полное заполнение экрана видеопроигрывателя.
q Оптимизирована работа создания бекапа базы данных, увеличена скорость работы создания бекапа, исправлена проблема, при которой иногда могли создаваться дубликаты файлов БД, все сообщения о создании и восстановлении базы данных, перенесены в языковые пакеты скрипта.
q В настройки скрипта добавлена возможность включения автоматического заполнения символьного кода для каталога публикаций. При включении данной настройки, если при добавлении публикации не был установлен символьный код для публикации, то для него автоматически будет добавлена первая буква заголовка публикации.
q Добавлена функция проверки файлов антивирусом DLE по крону. Для того чтобы выполнить проверку вам необходимо задать на вашем хостинге запуск скрипта http://site.ru/cron.php?cronmode=antivirus, по результатам проверки, если на вашем сервере будут обнаружены неизвестные или не соответствующие сделанному ранее снимку системы файлы, то на E-mail указанный в настройках скрипта будет отправлено соответствующее уведомление.
q В настройки скрипта добавлена возможность устанавливать количество новостей на страницу, которые будут показываться при просмотре мобильной версии сайта. Тем самым вы можете устанавливать раздельное количество публикаций на страницу для обычной версии сайта и для мобильной.
q Для шаблонов краткой и полной новости (shortstory.tpl и fullstory.tpl) добавлены новые теги [xfnotgiven_X]...[/xfnotgiven_X], которые выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где X это имя дополнительного поля. Тем самым оформление дополнительных полей в новостях становится еще более гибким и вы можете комбинировать различное оформление в зависимости от того, было ли поле написано или нет.
q Блок вывода популярных новостей полностью переведен на использование шаблонной системы, данный блок использует файл шаблона topnews.tpl и вы можете использовать в нем следующие теги: {title} - выводит заголовок новости, {link} - выводит ссылку на новость, {image-x} выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости, {text} - выводит полностью краткое содержание новости, {text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.
q Вывод похожих новостей в полной новости полностью переведен на использование шаблонной системы, данный блок использует файл шаблона relatednews.tpl и вы можете использовать в нем следующие теги: {title} - выводит заголовок новости, {link} - выводит ссылку на новость, {image-x} выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости, {text} - выводит полностью краткое содержание новости, {text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления найденных похожих новостей при просмотре полной новости.
q При выводе новостей с использованием пользовательского тега custom, в шаблоны добавлено использование новых тегов: {image-x} выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости, {text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. Тем самым вы получаете новые инструменты для гибкого вывода новостей на страницах с использованием пользовательского тега custom.
q Внесены изменения в алгоритмы показа рейтинга новостей при просмотре полных новостей. Тег {rating} выводит только непосредственно графический рейтинг новости, а для вывода количества проголосовавших пользователей, для шаблона полной новости (fullstory.tpl) добавлен новый тег {vote-num} который и выводит количество пользователей, выставивших рейтинг для данной новости. Тем самым оформление новостей стало гибче и данная информация может выводиться отдельно от самого рейтинга.
q Внесены изменения в алгоритмы работы настроек групп, касающиеся разрешения на удаление всех новостей. Если пользователю разрешено удалять все новости, но при этом также указаны и доверительные разделы, в которых он может редактировать новости, то данные настройки действуют также и на удаление новостей. Другими словами, пользователи не смогут удалять новости, не находящиеся в доверительных ему категориях.
q Внесены изменения в алгоритмы работы настроек групп, касающиеся разрешения на публикацию новостей без модерации. Если пользователю не разрешено публиковать без модерации, и при этом разрешен доступ к админпанели скрипта, то при добавлении новостей в админпанели, они также будут отправляться только на модерацию, и без модерации публиковать новости данные пользователи больше не смогут.
q Внесены изменения в алгоритмы работы настроек групп, касающиеся разрешения на редактирование собственных новостей. Если пользователю разрешено редактировать новости, разрешен доступ к админпанели скрипта, но при этом запрещена публикация новостей без модерации. То при редактировании уже опубликованных новостей в админпанели скрипта, они автоматически будут уходить опять на модерацию.
q Исправлена недавно допущенная яндексом ошибка по выдаче проиндексированных страниц из облака тегов для сайтов в кодировке windows-1251, содержащий в URL кириллицу. Суть данной ошибки состоит в том, что с недавних пор поисковая система Яндекс стала принудительно изменять кодировку URL на UTF-8, оставив при этом корректную индексацию страниц, в результате чего страницы поисковиком индексируются и показываются в результатах поиска на Яндексе, однако при переходе с Яндекса на эти страницы, поисковик принудительно менял кодировку символов и отправлял уже по несуществующему адресу. Несмотря на сообщения поисковой системе о наличии явной проблемы со стороны поисковика, данная проблема так и не была ими исправлена. В связи с этим данная проблема была решена со стороны DLE, для сайтов имеющих кодировку windows-1251, скрипт автоматически определяет кодировку входящего URL и при необходимости ее принудительно перекодирует.
q Исправлена проблема со скачиванием файлов через скрипт, но загруженных по FTP, если их название содержит буквы разного регистра.
q Исправлена проблема, при которой ролики Youtube, проигрывавшиеся в стандартном плеере Youtube, выводились всегда поверх любых окон.
q Исправлена проблема, при которой во время импорта новостей из RSS, если в новости есть кавычки, добавляется их некорректное двойное экранирование.
q Исправлена проблема, при которой скриптом допускалось использование пробелов в E-mail адресах, указываемых при регистрации на сайте.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.2:

q Добавлена глобальная система жалоб на сайте. Все зарегистрированные пользователи на сайте могут отправить администрации сайта жалобы на новости, персональные сообщения, комментарии. Для этого в шаблоны персональных сообщений, комментариев, новостей (pm.tpl, comments.tpl, shortstory.tpl, fullstory.tpl) добавлена поддержка тегов [complaint]текст[/complaint], которые выведут текст, указанных в тегах в виде ссылки на написание жалобы, на данную конкретную новость, персональное сообщение, или комментарий. Отправка жалоб с сайта осуществляется при помощи технологии AJAX без перезагрузки страницы. Управление поступившими жалобами осуществляется в админпанели скрипта, в специальном отдельном разделе управления жалобами. При этом в данном разделе в зависимости от типа жалобы будут доступны быстрые ссылки на реагирование на жалобы. Например, редактирование пользователя, редактирование и удаление комментария или новости. Доступ к данному разделу админпанели настраивается в настройках групп. Тем самым представлена новая система реагирования на спам в комментариях или персональных сообщениях, или например, на ошибки или недоработки в новостях.
q Для персональных сообщений добавлена функция игнорирования нежелательных пользователей. При получении персонального сообщения получатель может добавить отправителя в список игнорируемых пользователей, после чего заблокированный пользователь не сможет больше отправлять ему персональные сообщения. Тем самым каждый пользователь на сайте может оградить себя от общения с нежелательными другими пользователями. При этом пользователь не может добавить в список игнорируемых, пользователей, находящихся в администраторских группах и которые могут редактировать пользовательские профили. Тем самым администраторская группа защищена от игнорирования. Также пользователь в любой момент может разблокировать игнорируемого пользователя в своем профиле на сайте.
q Существенно расширены возможности файла запуска автоматического бэкапа БД. Данный файл был переименован в файл cron.php в корне и может выполнять следующие функции при его запуске по крону:

- Создание резервной копии базы данных. Для запуска данного режима просто запустите файл cron.php без указания ему параметров.
- Создание карты сайты сайта. Для запуска данного режима запустите файл с параметром cron.php?cronmode=sitemap
- Оптимизация базы данных. Для запуска данного режима запустите файл с параметром cron.php?cronmode=optimize
q В настройки скрипта добавлена возможность включать контроль URL ЧПУ. Например, при отключенной опции, адреса: http://site.ru/id-имя новости.html и http://site.ru/id-любой текст.html будут вести на одну и ту же страницу. При включении данной опции, будет осуществляться 301 редирект на верный адрес. Данная опция полезна для SEO и при смене ЧПУ адресов новости или при смене категорий у новостей. Данный контроль позволит поисковикам быстрее переиндексировать новость по ее новому адресу. Также данный контроль проверяет корректный адрес URL и при просмотре публикаций в категориях.
q Добавлен новый плеер для проигрывания FLV, MP4, MP3, Youtube на сайте. Данный плеер обладает всеми возможностями проигрывания, что и старый плеер, однако имеет ряд существенных улучшений. К таковым относится использование нового API сервиса Youtube, что позволяет проигрывать любое видео с сервиса, включая видео, содержащие рекламу. Также новый плеер обладает новым, улучшенным и качественным интерфейсом, позволяет также пользователям переключать размеры картинки проигрываемого видео, а также ряд других новшеств, о которых будет написано ниже.
q В настройки стандартного видеопроигрывателя добавлена возможность включения показа первого кадра видео в качестве превью картинки.
q Добавлена возможность назначать собственную обложку для видеопроигрывателя по умолчанию, если никакой картинки не указано в теге вставки видео. Обложки располагаются в шаблоне в файлах /шаблон/dleimages/videopreview.jpg для обычного видео, и /шаблон/dleimages/youtubepreview.jpg для видео с сервиса Youtube.
q Добавлена возможность устанавливать для видео размеры видеобуфера, который будет предварительно загружаться перед началом проигрывания видео. Увеличение буфера позволяет сделать более плавное воспроизведение видео без пауз при медленном интернет соединении, уменьшение буфера позволяет ускорить подготовку видео к воспроизведению и начать воспроизведение видео быстрее.
q Расширены возможности установки водяного знака на видео. Вы можете задать в настройках плеера местоположение водяного знака (слева, по центру, справа), а также степень прозрачности водяного знака.
q Добавлена возможность устанавливать в настройках видеоплеера качество воспроизводимого видео с сервиса Youtube. Вы можете установить качество от низкого до HD 720p.
q Добавлена возможность воспроизведения на сайте потокового видео по протоколу RTMP. Для этого используется тег [videо=rtmp://сервер потокового видео, путь до файла на потоковом сервере], например [videо=rtmp://site.ru/livesteam/,mp4:files/file.f4v]. При наличии потокового сервера вы можете организовывать воспроизведение видео файлов с перемоткой в любую точку видео, независимо от загруженного буфера видео. Подробнее о протоколе RTMP вы можете прочитать на http://ru.wikipedia.org/wiki/RTMP
q BB тег [yоutube=http://....] был переименован в тег [mediа=http://....], т.к. функциональность данного будет существенно расширяться и данный тег будет предназначен не только для воспроизведения видео с сервисов youtube или rutube, но и для воспроизведения видео с других видео хостингов.
q Для тега [mediа=http://....] добавлена возможность указания размеров видеоплеера непосредственно в теге. Например [mediа=300x250,http://....], в данном случае для видео плеера будут установлены размеры 300 пикселей по ширине и 250 по высоте. Указание размеров видео является необязательным, и если размеры не указаны, то будут использованы размеры, указанные в настройках скрипта.
q Добавлена возможность при написании новости и использовании тегов для вставки видео, устанавливать размеры видеоплеера непосредственно для данной новости и для каждого конкретного тега. Например [videо=300x250,http://site.ru/video.flv], в данном случае для видео плеера будут установлены размеры 300 пикселей по ширине и 250 по высоте. Указание размеров видео является необязательным, и если размеры не указаны, то будут использованы размеры, указанные в настройках скрипта. Также вы можете устанавливать не только размеры в пикселях, но и процентное соотношение размеров.
q Добавлена возможность при написании новости и использовании тегов для вставки mp3 аудио файлов, устанавливать размеры плеера непосредственно для данной новости и для каждого конкретного тега. Например [audiо=300x250,http://site.ru/audio.mp3]. Также вы можете указать только ширину плеера, без указания высоты, например [audiо=300,http://site.ru/audio.mp3]. Указание размеров видео является необязательным, и если размеры не указаны, то будут использованы размеры, указанные в настройках скрипта.
q Добавлена возможность редактирования пользователей непосредственно с сайта не только для группы администраторов, но и для всех групп пользователей, имеющих разрешение на редактирование пользователей в настройках групп.
q В админпанели скрипта, в разделе управления ключевыми словами облака тегов, добавлена разбивка ключевых слов по страницам, а также добавлена удобная навигация по данным страницам, что значительно упрощает редактирование большого количества ключевых слов, находящихся в облаке тегов.
q В админпанели скрипта, в разделе управления ключевыми словами облака тегов, добавлена возможность массового выделения и удаления ненужных ключевых слов для облака тегов.
q Добавлена возможность установить в настройках скрипта, лимит по времени в течении которого, после регистрации, пользователю будет запрещено добавлять публикации на сайте. Данная возможность предотвратит регистрацию спамеров только для того чтобы добавить новость, и эффективна при бане пользователя, он не сможет сразу добавлять новости опять, если его аккаунт ранее был забанен.
q Добавлена возможность установить в настройках скрипта, лимит по времени в течении которого, после регистрации, пользователю будет запрещено добавлять комментарии на сайте. Данная возможность предотвратит регистрацию спамеров только для того чтобы добавлять комментарии, и эффективна при бане пользователя, он не сможет сразу добавлять комментарии опять, если его аккаунт ранее был забанен.
q Внесены изменения в систему публикации статей. Так как часто пользователи строят свои сайты исключительно с использованием дополнительных полей, скрипт больше не требует обязательного заполнения краткой новости при публикации статей на сайте.
q Для шаблона вывода всех ключевых слов из облака тегов (tagscloud.tpl) добавлен новый тег {tags limit="x"}, где x это количество самых популярных тегов, которое будет выведено на странице. Например, вы можете на данной странице вывести весь список ключевых слов тегом {tags} либо вывести на данной странице только 100 самых популярных ключевых слов, тегом {tags limit="100"}
q В настройки скрипта добавлена возможность указания местоположения навигации по страницам новостей. Вы можете отключить вывод навигации, выводить ее наверху или внизу новостей, либо выводить одновременно наверху и внизу новостей.
q Добавлена проверка на реальное существование адреса E-mail, при смене адреса в настройках профиля пользователем, если на сайте включена расширенная регистрация, требующая активации E-mail адреса. В данном случае при смене E-mail в профиле, пользователю будет отправлено письмо с активацией на новый адрес, которое он должен подтвердить, для завершения процедуры смены E-mail адреса.
q Увеличена скорость работы сайта в случае использования RSS информеров, и в случае если внешние сайты по каким либо причинам перестали отвечать, например, стали недоступны.
q В настройки скрипта добавлена возможность устанавливать количество статей на страницу, которые были найдены в результате поиска. Ранее данное количество было привязано к общим настройкам количество новостей на страницу, что перестает отвечать растущим требованиям по оформлению сайта, когда общие настройки могут быть установлены в нулевое значение.
q Добавлен учет настроек групп, при перестроении новостей в админпанели скрипта. Ранее при перестроении публикаций в админпанели скрипта, настройки групп не учитывались, а учитывались только настройки скрипта.
q В шаблон панели авторизации (login.tpl) добавлена поддержка нового тега {group-icon}, предназначенного для вывода иконки группы пользователя.
q В настройки скрипта, в разделе настроек E-mail, добавлена возможность указания дополнительных параметров для функции PHP Mail(). Данная возможность позволяет принудительно установить параметры для отправки писем, например, некоторые серверы требуют принудительного указания отправителя через флаг -f, и т.д.
q В настройки скрипта, в разделе настроек E-mail, добавлена возможность указания E-mail адреса, который будет использоваться в качестве авторизации отправителя на SMTP сервере. Например некоторые бесплатные почтовые сервисы типа yаndex.ru, требуют чтобы при использовании их сервиса отправителем при авторизации был указан Е-mail адрес, зарегистрированный на их сервисе.
q Добавлена поддержка тегов [group] и [not-group] при предосмотре карточки профиля пользователей (шаблон profile_popup.tpl).
q Добавлена возможность, в админпанели скрипта при редактировании новостей, массово назначать нового автора публикациям.
q Добавлена возможность для администраторов сайта в админпанели удалять информацию о установленных сторонних модулях, непосредственно из админпанели скрипта. Также в случае если для стороннего модуля не указана или отсутствует иконка, то используется стандартная иконка скрипта для данного модуля.
q В настройки групп пользователей добавлена возможность разрешать или запрещать участие в голосованиях на сайте для определенных групп пользователей.
q При редактировании профиля пользователя на сайте, добавлен контроль вводимых IP адресов, предназначенных для блокировки доступа к аккаунту для определенных подсетей. В случае ввода некорректного адреса, данная информация не будет добавлена в базу данных. Что предотвращает случайную блокировку пользователями самих себя, когда они вводят вместо IP адресов, некорректную информацию в профиле.
q Внесены небольшие изменения в скрипте для полной поддержки нового браузера IE9.
q Фреймворк jQuery и WYSIWYG редактор были обновлены до актуальных версий.
q Исправлена проблема, при которой, невозможно было вставить ссылку на картинку без выравнивания в ББ редакторе.
q Исправлена проблема, при которой перестроение публикаций в админпанели теряло описание атрибутов title для картинок, если для них не были заданы собственные атрибуты.
q Исправлена проблема в UTF-8 версии скрипта, при которой могли неверно обрабатываться HTML атрибуты в тегах, если они содержать русские символы.
q Исправлена проблема, при которой не скачивались загруженные через скрипт файлы, содержащие в своем имени несколько точек подряд.
q Исправлена проблема, при которой при экспортировании RSS в Яндекс новости, Яндекс отклонял экспорт, если новость находилась в нескольких категориях, т.к. для яндекса необходимо указывать одну категорию. В RSS потоке, предназначенном для яндекса, будет указана только одна самая первая категория.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 9.0:

q В админпанели добавлен новый раздел управления облаком тегов. Доступ в данный раздел настраивается в настройках групп, вы можете, как разрешить пользование данным разделом для определенных групп, так и запретить. В данном разделе вы можете редактировать и удалять ключевые слова из облака тегов. Также в случае переименования тега в уже существующее имя, то скрипт автоматически найдет и удалит дубликаты непосредственно из публикации.
q В шаблон полной новости (fullstory.tpl) добавлены новые теги [related-news] текст [/related-news], которые выводят информацию, только если для данной новости присутствуют похожие новости, в противном случае информация удаляется из шаблона. Тем самым вы можете не выводить лишнее форматирование в шаблоне, предназначенное для вывода похожих новостей, если таковых для новости нет.
q В шаблоны кратких и полных новостей (shortstory.tpl, fullstory.tpl) добавлены следующие теги: [poll] текст [/poll] выводят текст в данных тегах, если для данной публикации задан опрос, [not-poll] текст [/not-poll] выводят текст в данных тегах, если для данной публикации не был задан опрос. Тем самым вы можете задавать различное оформление для опросов на сайте, а также для публикаций, не содержащих опросов.
q В админпанели на главной странице, вкладка отображения общей статистики сайта и очистки кеша перенесена на первую вкладку, для большего удобства работы с админпанелью скрипта. Также для пользователей имеющих доступ в админпанель, но не имеющих администраторских прав, добавлена также вкладка с общей статистикой сайта и быстрым доступом к редактированию новостей, находящихся на модерации и комментариям, если они имеют соответствующий доступ в настройках групп.
q Все функции админпанели на главной странице, такие как очистка кеша, сохранение блокнота, отписка пользователей от получения рассылки уведомлений о новых комментариях, перенесены на использование технологии AJAX, т.е. выполняются без перезагрузки страницы.
q Добавлена возможность просмотра всех голосований на сайте. Вы можете разместить в шаблоне специальную ссылку, при клике на которую, в специальном всплывающем окне посетителю будут показаны все голосования на сайте, а также их результаты. Пользователю показывается полный архив голосований, включая голосования, прием голосов по которым, закончен. В случае если голосование активно и посетитель еще не голосовал в данном опросе, то он сможет сразу принять участие в выбранном опросе.
q Добавлена возможность при массовой рассылке сообщений в админпанели, выбирать одновременно несколько групп пользователей, кому будут отправлены сообщения.
q Добавлен новый онлайн редактор для редактирования шаблонов сайта в админпанели. Новый редактор позволяет редактировать любые файлы шаблонов, находящиеся в папке шаблонов, а не только стандартные файлы. Также редактор позволяет помимо файлов tpl, также редактировать файлы стилей CSS и javascript файлы. Файлы при этом могут располагаться не только в основной папке шаблона, но и во внутренних папках шаблона. Выбор файлов для редактирования, а также редактирование и сохранение отредактированных файлов осуществляется при помощи технологии AJAX без перезагрузки страницы. Также помимо всего прочего при редактировании файлов весь текст выводится с использованием специализированной подсветки, что облегчает редактирование кода. Также вы можете создавать новые файлы для шаблона с расширением .tpl непосредственно в админпанели без использования FTP доступа.
q В целях повышения защиты сайта от спама добавлена поддержка сервиса reCAPTCHA. Вы можете в настройках скрипта установить какой тип каптчи будет использован на сайте, при этом также задать публичный и приватный ключ непосредственно для своего собственного сайта. Также в настройках скрипта вы можете выбрать, какую тему использовать на сайте для вывода виджета. Для вывода виджета на сайте в шаблонах используются теги: [recaptcha]{recaptcha}[/recaptcha]
q В шаблоны кратких и полный новостей (shortstory.tpl, fullstory.tpl) добавлены следующие теги: [profile] текст [/profile], которые выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля. Тем самым вы можете задать в шаблонах, например [profile]{login}[/profile], которые выведут логин автора с прямой ссылкой на профиль. Данные теги, также например актуальны при использовании их в мобильной версии сайта, где минипрофиль нежелателен из-за ограниченных размеров экрана мобильного телефона.
q В адмипанели добавлена система динамического контроля прав на запись в папки и файлы, если они того требуют. Например, при редактировании настроек или шаблонов, на них отсутствуют права на запись, скрипт уведомит вас об этом. Данный контроль полезен, например, при переносе сайта на другой сервер, и многие забывают при этом права на запись.
q В админпанели добавлен новый модуль "Перестроение публикаций". В данном разделе вы можете перестроить свои новости с учетом новых настроек или изменений в файлах скрипта. Как известно все новости на сайте хранятся в базе данных в готовом сформированном виде, и например для вступления изменений некоторых настроек скрипта необходимо новость пересохранить. Данный модуль производит перестроение всех новостей в базе данных. Данный модуль построен полностью на технологии AJAX, отображает шкалу выполнения операции, в случае, какого либо сбоя в перестроении, или например временном падении сервера, отображает соответствующую ошибку и позволяет продолжить процедуру с момента сбоя.
q Из шаблона login.tpl убрана поддержка PHP кода, данный файл шаблона переведен полностью на поддержку обычного файла шаблона и обычных шаблонных тегов. Список поддерживаемых тегов в данном шаблоне вы можете прочитать в документации по скрипту. Несмотря, на то, что это немного ограничивает в функциональности, данное нововведение позволяет изолировать шаблон от PHP логики. Очень часто злоумышленники используют этот файл для атак на сервер, если шаблон был скачан из сомнительных источников.
q В админпанели, при массовой рассылки E-mail сообщений, добавлен новый механизм отправки сообщений, позволяющий в случае сбоя на сервере в процессе рассылки сообщений, продолжить рассылку с момента сбоя, нажав при этом кнопку "Продолжить" на этой же странице, рассылка при этом будет автоматически продолжена с момента последнего отправленного сообщения. При этом при рассылке отображается удобный визуальный индикатор отправленных сообщений.
q Добавлена возможность отправки автору публикации уведомления о удалении новости не только при ее удалении в админпанели, но при ее удалении с сайта.
q Добавлена возможность отправки модераторами сайта, уведомлений авторам публикаций, например они могут отправить сообщение автору публикации о необходимости доработки новости. Отправка данного уведомления происходит с использованием технологии AJAX.
q Улучшена совместимость скрипта с различными конфигурациями серверов, позволяющая избегать дополнительных различных настроек сервера.
q Полностью переписаны механизмы отправки E-mail сообщений с сайта администрации и другим пользователям. Проверка всех введенных данных, а также непосредственно отправка сообщения теперь происходит при помощи технологии AJAX без перезагрузки страницы, что не только экономит ресурсы сервера, но и позволяет в случае ошибочного ввода какой либо информации, например кода безопасности, исправить ошибки без потери введенной ранее информации.
q При просмотре непрочитанных публикаций на сайте посетителем, в случае отсутствия новых публикаций, для посетителя выводится более понятное сообщение о том, что новых публикаций нет, а не общее сообщение об ошибке, как было ранее.
q Для BBCODES редактора добавлена поддержка тегов типа "список". Вы можете использовать как обычный список, так и нумерованный список, допускается также вложение списков друг в друга.
q При проверке публикаций пользователей в админпанели, добавлена возможность отправлять им персональным сообщением уведомления без удаления новости. Например, вы можете сообщить авторам о необходимой доработке публикации, прежде чем она будет опубликована на сайте, или сообщить о необходимости ее доработки уже после публикации на сайте. Отправка уведомлений осуществляется с использованием технологии AJAX, без перезагрузки страницы.
q Добавлена поддержка кавычек для дополнительных полей новостей, при выборе типа дополнительного поля "Список (Select)".
q При редактировании статических страниц, добавлена защита от использования дублирующих имен и URL для статической страницы, также добавлено автоматическое конвертирование URL, если имя содержит недопустимые для URL символы.
q Полностью переписаны скрипты для работы с AJAX, все функции были переписаны для использования jQuery, тем самым собственный класс использовавшийся ранее был убран из скрипта, что позволило сократить размеры используемых JS файлов, и тем самым немного ускорить загрузку страниц и кода и в браузер.
q Для массовых действий при редактировании публикаций была добавлена возможность, для выбранных новостей, назначить ключевые слова для облака тегов.
q Добавлена возможность уведомления различных поисковых систем о наличии новой карты сайта. Уведомление происходит сразу шести поисковых систем: Google, Yandex, Yahoo, Bing, Weblogs, Ask. При этом отправка карты сайта для всех поисковых систем осуществляется в один клик, при помощи технологии AJAX. При этом скрипт проверяет ответ от поисковика и в случае если он не принимает карту, сообщает об этом.
q Все три стандартных шаблона, которые идут с дистрибутивом скрипта, были заменены на абсолютно новые, современные шаблоны. Новые шаблоны демонстрируют различные возможности скрипта и каждый является по своему уникальным, со своим набором различных функций, и оформления.
q Увеличена производительность скрипта при отображении комментариев на сайте, а также снижена нагрузка на БД при показе комментариев.
q Внесены изменения в алгоритм обработки дополнительных полей для новостей. В случае если для поля задан тип "одна строка", то данное поле будет автоматически обрабатываться в безопасном режиме, без возможности использования HTML, а также для данного поля не будет производиться обработка ББ тегов. Данное изменение добавляет еще больше гибкости при оформлении полей в шаблоне, т.к. нет надобности включать безопасный режим в настройках, только из-за полей этого типа, также например, к полю не будет применяться, например автоматическая конвертация ссылки в кликабельную, что позволяет использовать собственно оформление, как ссылки, так и описания ссылки. Также помимо всего прочего снижена нагрузка на сервер при редактировании новостей, содержащих дополнительные поля.
q Улучшена система автоматической помощи при заполнении облака тегов. Добавлена поддержка управления кнопками, а также запятые при вводе слов проставляются автоматически.
q Улучшена система защиты от регистрации визуально похожих логинов на сайте. Например, не допускается использование нескольких пробелов подряд при регистрации пользователя на сайте.
q Улучшена система безопасности, контролирующая защиту от подбора паролей пользователей на сайте, методом перебора паролей.
q Вывод блока популярных новостей переведен на использование тегов "ul" и "li", что позволяет использовать намного больше возможностей для оформления этого блока в шаблоне.
q Небольшие исправления, направленные на исправление проблем, связанных с прохождением валидности некоторых страниц сайта.
q Переработана система навигации по страницам публикаций. Из навигации исключены ссылки типа http://site.ru/page/1/, которые являются дублирующими страницу http://site.ru/, что способствовало появлению дубликатов страниц в поисковых системах.
q Улучшена система автоматического определения размеров окна смайлов, позволяющая избегать появления горизонтальной полосы прокрутки при выборе и вставке смайлов.
q Добавлена поддержка кириллических доменов .рф при создании карты сайта и при уведомлении поисковых систем о наличии новой карты. Поисковые системы Yahoo и Ask на данный момент не поддерживают кириллические домены.
q Добавлена поддержка кириллических доменов .рф при проигрывании видео и аудиофайлов с данных доменов.
q Добавлена поддержка кириллических доменов .рф в e-mail адресах. Внимание: DLE не осуществляет доставку писем, он лишь дает команду почтовому серверу на отправку письма. А вот поддержки кирилических доменов почтовыми серверами еще не введено или введено весьма ограниченно, далеко не у всех, т.к. такие адреса противоречат спецификации RFC. Поэтому не рекомендуется использовать кириллические домены в качестве e-mail адресов, т.к. велика вероятность что будут проблемы с доставкой почты. Полноценная поддержка таких доменов со стороны серверов, появится наверное не ранее чем через 2-3 года, когда будут изменены спецификации. Мы добавили поддержку только со стороны скрипта, как задел на будущее, чтобы именно он не блокировал отправку писем.
q Обновлен WYSIWYG редактор до актуальной версии, полный список изменений вы можете увидеть на странице: http://tinymce.moxiecode.com/js/tinymce/changelog.txt, а также был проведен редизайн панели WYSIWYG редактора.
q Добавлена поддержка браузера IE9 Beta.
q В состав дистрибутива включен robots.txt для управления поисковыми роботами на сайте. В данном файле мы постарались создать наиболее благоприятные условия для индексации вашего сайта, при котором исключается индексирование ненужных, по нашему мнению, для индекса страниц, что позволяет убрать из индексации малозначимую информацию, повысить релевантность сайта, а также снизить нагрузку на сервер от поисковых роботов при индексации. Например, из индекса были убраны все служебные страницы, такие как добавление новости, регистрация, персональные сообщения. Также было запрещены к индексированию профили пользователей и просмотр последних комментариев на сайте, что крайне положительно сказывается на нагрузке на сайт.
q Исправлена проблема, при которой в определенных случаях, пользователи могли видеть скрытый текст, опубликованный в кратких новостях, если при этом в настройках групп им был запрещен просмотр скрытого текста.
q Исправлена проблема, при которой спам роботы могли обходить блокировку по IP, установленную в фильтре IP адресов в админпанели, используя AJAX возможности скрипта.
q Исправлена проблема, при которой неверно отображались значения доп. полей, заданные по умолчанию, если в них содержались спец. символы.
q Исправлена проблема, при которой поиск на лету осуществлял также поиск новостей, которые еще не были опубликованы или их дата публикации еще не наступила.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.


Установка и обновление скрипта

Установка скрипта на сервер

Установка скрипта на сервер проходит в автоматическом режиме и не должная вызывать особых проблем, но вам необходимо выполнить некоторые действия по настройке прав доступа на папки.

1. Для начала скопируйте все файлы из папки upload в данном архиве на ваш сервер.
2. Установите для папки templates и всем вложенным в нее папкам права на запись (CHMOD 777)
3. Установите для всех файлов в папке templates права на запись (CHMOD 666)
4. Установите права для записи (CHMOD 777) для папок backup, uploads, а также для всех папок, находящихся внутри них.
5. Установите права для записи (CHMOD 777) для папок /engine/data/, /engine/cache/, /engine/cache/system/.
6. Запустите файл install.php в URL вашего браузера и следуйте его инструкциям.

Внимание: чистая установка скрипта приводит к удалению данных ранее установленного скрипта DLE, для обновления установленного скрипта читайте инструкцию по обновлению ниже.

Автоматический инсталлятор проверит все необходимые файлы и настроит подключение к базе данных. После завершения установки вы сможете посмотреть работу скрипта на демонстрационной странице http://website.com/index.php. Для доступа к админпанели необходимо запустить http://website.com/admin.php

Обновление скрипта с более старых версий или демоверсий:

1. Создайте резервную копию базы данных и всех файлов скрипта на сервере.
2. Обновите все файлы из папки /upload/ вашего архива (за исключением /templates/). Внимание: Файлы из архива дистрибутива, нужно заливать на сервер поверх существующих, а не удалять предварительно папки на сервере.
3. Запустите файл http://website.com/upgrade/index.php, и следуйте дальнейшим инструкциям.
4. Удалите папку /upgrade/ и файл install.php с вашего сервера.
5. В админпанели на главной странице выберите "Очистку кеша", а также полностью очистите кеш браузера, чтобы он скачал новые JS файлы с сервера, а не использовал старые файлы из кеша
6. Внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте вместе со ссылкой на дистрибутив.
7. Проверьте настройки скрипта в админпанели.

Внимание: обновление скрипта возможно только с версий 3.5 и выше, поддержка более ранних версий прекращена.


Начало работы и шаблоны

Одной из особенностей движка является то, что в него можно подключить любой существующий дизайн не испытывая при этом каких-либо ограничений. Движок поддерживает работу с несколькими шаблонами одновременно. Все шаблоны находятся в папке /tеmplates/. Каждая вложенная папка в этой папке является отдельным макетом сайта. Поэтому если вы скачали новый скин для движка просто скопируйте его в папку и разрешите его использование в админ панели. Также мы можете разрешить смену дизайна для посетителей вашего сайта и они сами смогут выбрать, как будет выглядеть их любимый сайт. Также вы можете установить количество новостей, выводимых на страницу, для этого зайдите в настройки скрипта и установите соответствующий параметр.

Внимание: В файлах шаблона вы можете использовать обычный html текст, либо можете использовать специальные теги, для вставки тех или иных возможностей, прочитать подробнее о допустимых тегах вы сможете в данном руководстве ниже в разделе Шаблоны.


Вывод новостей на страницах

Основной макет вашей страницы находится в файле шаблона main.tpl именно этот файл скрипт DLE подгружает в первую очередь и к нему подключаются все другие компоненты движка. Остановимся на основных из них. {AJAX}, {info}, {content}, {custom} именно эти теги отвечают за правильный вывод новостей.

Тег {AJAX} выводит служебные скрипты JavaScript необходимые для нормальной работы движка в целом и технологии AJAX в частности. Рекомендуется размещать в самом начале шаблона после тега <body>

Тег {info} выводит служебную информацию и ошибках о произведенных действиях (например "Вход не выполнен, неверный пароль" или "Необходимо заполнить все поля") рекомендуется устанавливать перед тегом {content}

Тег {content}, отвечает за непосредственный вывод статей и прочих встроенных модулей в движок

Тег {tags}, отвечает за вывод облака тегов (специальных ключевых слов добавленнных в новость)

Теги [sort]{sort}[/sort], отвечают за вывод выбора пользователем порядка сортировки новостей, если это разрешено в настройках скрипта

Тег {custom}, отвечает за вывод статей в пользовательском формате, имеет следующие параметры:

{custom id="1,2" category="2,3,5-8" author="x" days="x" template="custom" aviable="global" from="0" limit="10" fixed="yes" order="date" cache="yes"}

Где

id это список ID новостей которые вы хотите вывести

category это список ID категорий, из которых производить выборку новостей, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет новости из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

template файл шаблона который будет использоваться при выводе новостей в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные для короткой новости.

aviable раздел в котором будет выводится запрашиваемые новости, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например aviable="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from номер новости с которой начнется вывод

limit сколько новостей будет выведено

order порядок сортировки новостей, может причинимать следующие значения:

date - сортировка новостей по дате

rating - сортировка новостей по рейтингу

reads - сортировка новостей по количеству просмотров

comments - сортировка новостей по количеству комментариев

title - сортировка новостей по заголовкам новостей

rand - сортировка новостей в случайном порядке

author логин автора новости, при указании данного параметра будут выводится только новости указанного автора. Допускается использование только одного автора. Например, тег {custom author="admin" limit="5"} выведет 5 новостей автора с логином "admin".

days указывает временной период, где x это количество дней за которые выводить публикации. Например, тег {custom days="2" limit="5"} выведет 5 новостей за 2 последних дня.

cache принимает значения yes или no - устанавливает кешировать вывод или нет, рекомендуется кешировать для снижения нагрузки.

fixed принимает значения yes, no или only- устанавливает учитывать ли при выводе публикаций, то что новости были зафиксированы или нет. В случае если указано значение only, то будут выводится только зафиксированные новости.

Внимание все параметры данного тега являются необязательными, необходимо указать только как минимум один любой параметр, все остальные параметры, если они не заданы, будут взяты из общих настроек скрипта. Например:

{custom id="1,2" order="date"} - выведет новости с ID 1 и 2 и отсортирует их по дате

{custom category="2,7" from="5" cache="yes"} - выведет новости из категорий 2 и 7 при этом количество новостей будет взято из настроек скрипта, а выборка будет осуществляться после 5 новости, отвечающей данному условию

{custom order="date" from="9" limit="5"} - выведет 5 последних новостей, начиная с десятой новости

Помните что каждое использование этого тега создает дополнительную нагрузку на базу данных, т.к. идет дополнительная выборка, поэтому используйте ее с умом если необходимо экономить на ресурсах.

Тег [aviable=раздел] текст [/aviable], выводит текст заключенный в теги если просматривается указанный раздел сайта:

Тег принимает параметры аналогичные параметру aviable тега {custom}. Вы можете комбинировать разделы при помощи "|", например userinfo|register|main

Для примера:

[aviable=userinfo|register|main] текст [/aviable]

будет выводить текст заключенный в теги, на главной, при регистрации и при просмотре профиля пользователя.

Внимание вы можете задать также тег [not-aviable=userinfo|register|main] текст [/not-aviable] который полностью противоположен тегу aviable и выводить текст везде кроме перечисленных разделов.

Тег [category=X]текст[/category], выводит текст заключенный в теги если просматривается указанная категория:

Тег принимает в качестве параметра ID категории, и допускает перечисление нескольких категорий

[category=1,2,3] текст [/category]

будет выводить текст заключенный в теги, если посетитель просматривает категории у которых ID равен 1 или 2 или 3.

Внимание вы можете задать также тег [not-category=1,2,3] текст [/not-category] который полностью противоположен тегу category и выводить текст везде кроме перечисленных категорий.

Тег [group=X]текст[/group], выводит текст заключенный в теги если пользователь принадлежит указанной группе пользователей:

Тег принимаем в качестве параметра ID группы, и допускает перечисление нескольких групп

[group=1,2,3] текст [/group]

будет выводить текст заключенный в теги, если посетитель является администратором, главным редактором или журналистом.

Внимание вы можете задать также тег [not-group=1,2,3] текст [/not-group] который полностью противоположен тегу group и выводить текст для всех, кроме перечисленных групп.

[page-count=1,2,3] текст [/page-count]

Будет выводить текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации. Данный тег позволит очень гибко настроить вывод той или иной информации, на определенной странице и полезен для информационных блоков и рекламы. Вы можете использовать данный тег совместно с другими, опеределяющими разделы сайта и категории.

Например, комбинация тегов [aviable=cat][category=1][page-count=1] текст [/page-count][/category][/aviable] выведут текст, только если пользователь просматривает первую страницу категории с id1, и при этом просматривает именно краткие новости, и при переходе на другую страницу в этой категории, данного текста он уже не увидит.

[not-page-count=1,2,3] текст [/not-page-count]

Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.

{banner_имя} этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.

[banner_имя] текст [/banner_имя] выводят текст заключенных в них, если указанный баннер выводится на странице сайта.

{inform_имя} этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[static=имя страницы] текст [/static]

будет выводить текст заключенный в теги, если посетитель просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую. Например [static=test1,test2,test3] текст [/static] будет выводить текст на страницах test1, test2 и test3

[not-static=имя страницы] текст [/not-static]

будет выводить текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую.

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов.


Теги при написании новостей

При написании новостей допустимо использование следующих тегов, если вы не используете WYSIWYG редактор:

[b] текст [/b] Выделяет текст жирным шрифтом

[i] текст [/i] Выделяет текст наклонным шрифтом

[s] текст [/s] Зачеркивает текст

[u] текст [/u] Подчеркивает текст

[code] текст [/code] отменяет использование форматирования текста заключенного в теги

[left] текст [/left] Выравнивает текст по левому краю

[center] текст [/center] Выравнивает текст по центру

[right] текст [/right] Выравнивает текст по правому краю

[url=ссылка] текст [/url] Вставка ссылки в новость

[leech=ссылка] текст [/leech] Полностью аналогичен тегу URL, за исключением того что производит шифрование ссылки

[email=ссылка] текст [/email] Вставка e-mail адреса в новость

[img] ссылка [/img] Вставка картинки новость

[img=выравнивание] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру

[img=выравнивание|свой текст для alt] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[color=цвет] текст [/color] Изменение цвета текста на указанный

[quote] текст [/quote] Цитата

[hide] текст [/hide] Скрывает текст от не зарегистрированного посетителя

{pagebreak} Разрыв страницы

[page=номер страницы] текст [/page] Вставка ссылки на указанный номер страницы внутри новости

[thumb] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку

[thumb=выравнивание] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру

[thumb=выравнивание|свой текст для alt] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[video=http://test.ru/video.avi] Позволяет установить проигрывание видеофайла в новости

[video=http://test.ru/video.avi|http://test.ru/sample.jpg] Позволяет установить проигрывание видеофайла в новости, а также картинку предосмотра для перед началом проигрывания.

[video=http://test.ru/video.flv,http://test.ru/video_hd.mp4] Позволяет установить проигрывание двух видеофайлов в новости, один файл используется для показа видео в обычном разрешении, второй с улучшенным HD разрешением

[videо=300x250,http://site.ru/video.flv] Данный тег позволяет установить размеры видео для данного конкретного тега

[video=rtmp://site.ru/livesteam/,mp4:files/file.f4v] Позволяет установить проигрывание RTMP потока видео. При наличии потокового сервера вы можете организовывать воспроизведение видео файлов с перемоткой в любую точку видео, независимо от загруженного буфера видео. Подробнее о протоколе RTMP вы можете прочитать на http://ru.wikipedia.org/wiki/RTMP

[audio=http://test.ru/music.mp3] Позволяет установит проигрывание MP3 в новости

[font=имя шрифта] текст [/font] Написание текста определенным шрифтом

[size=размер] текст [/size] Написание текста определенным размером шрифта

[spоiler] текст [/spoiler] Скрывает указанный в теге текст и показывает его при клике на него

[spоiler=Заголовок] текст [/spoiler] Выводит собственный заголовок по щелчку на который будет показан скрытый текст

[media=ссылка на страницу с видео] предназначен для публикации видео на сайте с таких видеохранилищ как youtube.com, rutube.ru, video.mail.ru, vimeo.com, smotri.com, gametrailers.com. В данном теге вы просто указываете URL страницы видеохранилища где размещено видео, скрипт автоматически распознает тип видеохранилища и вставит нужный HTML код для просмотра видео.

[media=300x250,http://....] Данный тег позволяет установить размеры видео для данного конкретного тега

[flash=ширина,высота] Путь к ролику [/flash] предназначенный для вставки флеш роликов в формате swf.

[list]

[*]пункт 1

[*]пункт 2

[/list] Вывод списка на сайте

[ol=1]

[*]пункт 1

[*]пункт 2

[/ol] Вывод пронумерованного списка на сайте

Небольшие пояснения к вставке кодов:

Например если вы хотите вставить картинку в текст то используйте тег [img]http://website/image.jpg[/img], если хотите ее выровнять по левому или по правому краю то используйте [img=left]http://website/image.jpg[/img], если же картинку нужно выровнять по центру то используйте следующее написание [center][img]http://website/image.jpg[/img][/center]. Аналогичный принцип действует и для тега [thumb]. Например, ваша статья содержит несколько страниц, и вы хотите на какой-либо странице помимо стандартной навигации между ними, зашитой в шаблоне, использовать свою ссылку на какую-либо страницу, то вставьте следующий код [page=3] для просмотра 3 страницы жми тут[/page] где 3 это номер страницы вашей новости.


Избранное / Фавориты

Возможности движка позволяют каждому зарегистрированному пользователю добавлять понравившуюся новость в свои закладки. Не путайте с закладками браузера. После авторизации на сайте каждый посетитель может добавить новость в закладки нажав на плюсик, после этого он может легко просмотреть новость или комментарии к ней, независимо от даты новости и не используя при этом поиск.


Персональные сообщения

Все авторизованные на сайте пользователи могут отправлять друг другу персональные сообщения. Данные сообщения в дальнейшем можно просматривать, удалять их, а также отвечать на них. Для этого используется определенный шаблон для их вывода. При редактировании этого шаблона будьте предельно внимательны. Чтобы не нарушить функциональность этого модуля. Для редактирования этого шаблона не требуется знание PHP, однако вы должны разбираться в HTML и его особенностях. Другими словами просто не изменяйте без особой надобности поля для ввода информации из форм.


ЧПУ и настройка

DataLife Engine использует в своей работе для вывода новостей ЧПУ (человеко-понятный URL), что позволяет тему статьи или любой другой текст добавить в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной, что приведет больше посетителей на ваш сайт с поисковых систем. Для работы ЧПУ необходимо чтобы на вашем сервере был установлен модуль modrewrite. Если Ваш сервер не поддерживает этого, то вы можете отключить эту функцию. Для этого вам необходимо обязательно удалить с корневого каталога файл .htaccess и при установке скрипта отключить поддержку этой функции. Для более корректной работы ЧПУ мы рекомендуем устанавливать скрипт в корневую папку вашего сайта.

При включенном ЧПУ ссылки будут имеют следующий вид

Полная новость

С использованием ЧПУ зависит от типа ЧПУ установленного в настройках скрипта

http://website.com/index.php?newsid=1234543 - без использования ЧПУ

Добавление новостей на сайт вашими посетителями

http://website.com/addnews.html - с использованием ЧПУ

http://website.com/index.php?do=addnews - без использования ЧПУ

Профиль пользователя

http://website.com/user/имя пользователя/ - с использованием ЧПУ

http://website.com/index.php?subaction=userinfo&user= имя - без использования ЧПУ

Регистрация на сайте

http://website.com/index.php?do=register - без использования ЧПУ

Обзор непрочитанных сообщений

http://website.com/newposts/ - с использованием ЧПУ

http://website.com/index.php?subaction=newposts - без использования ЧПУ

Вывод всех новостей

http://website.com/lastnews/ - с использованием ЧПУ

http://website.com/index.php?do=lastnews - без использованиия ЧПУ

Вывод всех новостей указанной категории

http://website.com/альтернативное имя категории/ - с использованием ЧПУ

http://website.com/index.php?do=cat&category=альтернативное имя - без использования ЧПУ

Вывод всех новостей за 2005 год

http://website.com/2005/ - с использованием ЧПУ

http://website.com/index.php?year=2005 - без использованиия ЧПУ

Вывод всех новостей за указанный месяц

http://website.com/2005/12/ - с использованием ЧПУ

http://website.com/index.php?year=2005&month=04 - без использования ЧПУ

Вывод всех новостей за указанный день

http://website.com/2005/12/01/ - с использованием ЧПУ

http://website.com/ index.php?year=2005&month=04&day=30 - без использования ЧПУ

Обратная связь с администрацией сайта и другими участниками

http://website.com/index.php?do=feedback

Каталог сайта (сортировка по символьному коду)

http://website.com/catalog/a/ - с использованием ЧПУ

http://website.com/index.php?catalog=а - без использованиия ЧПУ

Вывод облака тегов

http://website.com/tags/ - с использованием ЧПУ

http://website.com/index.php?do=tags - без использованиия ЧПУ

Правила сайта

http://website.com/rules.html - с использованием ЧПУ

http://website.com/index.php?do=rules - без использованиия ЧПУ

Ссылки для вывода всех новостей указанной категории вы должны самостоятельно добавить в дизайн вашей страницы. Более подробно о создании категорий читайте ниже.


Поддержка Смартфонов

Datalife Engine позволяет автоматически определять с использованием чего посетитель заходит на ваш сайт. И в случае если пользователь заходит на ваш сайт с мобильного аппарата, то DataLife Engine способен распознать это и подготовить для вывода специальную облегченную версию вашего сайта, с минимумом графики и использованного для передачи трафика.

Для включения данной возможности вам необходимо в Админпанели в настройках скрипта включить пункт: Включить автоматическую поддержку смартфонов, там же в настройках скрипта вы можете включить вывод в новостях картинок или отключить. Также можно принудительно включить отображение версии сайта для смартфонов, для этого нужно перейти по ссылке http://site.ru/index.php?action=mobile

Также в вашей папке шаблонов /templates/ должна находится папка с шаблоном smartphone именно этот шаблон используется для вывода сайта в случае если пользователь зашел на ваш сайт с использованием мобильного телефона. В данном шаблоне вы можете использовать все теже возможности что и в обычном шаблоне. Все теги и возможности полностью идентичны обычному шаблону. Но мы рекомендуем использовать самый минимум и не забывать о размерах экрана мобильного телефона. В архиве дистрибутива мы подготовили один такой стандартный шаблон с самым минимумом информации и размером. На него мы и рекомендуем опираться, при создании собственного шаблона.


Система жалоб на грамматические ошибки на сайте

В скрипте DataLife Engine присутствует поддержка системы жалоб посетителями сайта, на допущенные грамматические или другие ошибки на сайте. Посетитель сайта, находясь на странице вашего сайта может выделить любой текст в браузере и нажать Ctrl+Enter и ему будет предложено отправить уведомление о грамматической ошибке в выделенном тексте. При этом пользователь может выделить любой текст на любой странице вашего сайта. Поэтому рекомендуем вам разместить какой либо блок-уведомление в какой либо видимой части вашего сайта, что у посетителей есть возможность отправлять уведомления администрации о грамматических ошибках на сайте. Управление жалобами на грамматические ошибки осуществляется в админпанели в разделе управления жалобами. Само уведомление отправляется с сайта с использованием технологии AJAX без перезагрузки страницы, и не доставляет неудобств пользователям.


Добавление новостей

Вход в админцентр осуществляется по адресу http://website.com/admin.php После авторизации вы сможете добавлять, редактировать и удалять новость, управлять пользователями и шаблонами, производить настройку скрипта, управлять картинками и многое другое.

При добавлении новости на сайт Вам необходимо задать заголовок статьи. Поле ЧПУ URL статьи является необязательным используется при включенных ЧПУ. Вы можете задать там свой текст, который будет в строке браузера, либо можете оставить его пустым, тогда текст будет сформирован из заголовка статьи, с учетом правил транслитации. Поле Дата задает дату новости, если отмечена галочка Текущая дата то будет автоматически вставлена текущая дата, с учетом коррекции времени, либо вы можете снять эту галочку, и ввести дату самостоятельно используя удобный календарь, нажав на значок рядом с полем. Если указать дату которая не наступила, то новость будет автоматически опубликована при наступлении указанной даты, при условии что новость допущена к публикации. Также вы можете выбрать категорию к которой принадлежит статья. После этого используя удобные кнопки для вставки тегов напишите вашу новость в кратком и полном описании, также если созданы дополнительные поля введите информацию и там. Внимание поле Полное описание не является обязательным, если оно пустое, то текст будет автоматически взят с Краткого описания. Используя ссылку [Загрузить картинку] вы сможете вставить в текст новости загруженные на сервер картинки либо загрузить непосредственно для этой статьи свою картинку. Также имеется возможность загрузки картинки непосредственно с другого сервера, минуя загрузку на собственный компьютер. Внимание если вы загружаете для этой статьи собственные картинки, то они будут автоматически удалены с сервера, при удалении новости.


Редактирование новостей

Редактирование новостей идентично их добавлению за исключением поля Дата. Вы можете либо не изменять дату, для этого оставьте отмеченным Не изменять дату новости, либо снимите с него флажок и установите на Текущая дата и время, либо введите свою дату используя календарь.


Личные настройки

В данном разделе вы сможете редактировать свой собственный профиль, изменить E-mail адрес, поменять дополнительные поля в виде полного имени, места жительства, номера ICQ, установить новый пароль.


Настройка системы

В данной разделе осуществляется общая настройка параметров системы, обратите внимание на то что настройка разбиты на разделы и для выбора раздела просто нажмите на соответствующую иконку. Пожалуй стоит остановиться на каждом пункте подробнее:

Название сайта – Введите название вашего сайта, например «Моя домашняя страница»

Домашняя страница сайта – Введите URL к главной странице, без указания имени файла, например http://website.com/ Обратите внимание на то что слеш на конце обязателен.

E-Mail адрес администратора – Адрес с которого будут отсылаться все письма с сервера для посетителей

Шаблон сайта по умолчанию – Выберите скин, который будет использоваться при отображении вашего сайта по умолчанию

Используемый язык – Выберите язык по умолчанию, который будет использоваться для вывода всех сообщений скрипта

Количество новостей на страницу – Укажите сколько новостей будет показываться при просмотре кратких статей

Включить WYSIWYG редактор при добавлении новостей с сайта - При добавлении новостей посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Включить WYSIWYG редактор в админпанели - Включает данный редактор в админпанели

Включить WYSIWYG редактор для комментариев и персональных сообщений - При добавлении комментариев посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Автоматическая разбивка длинных слов – Введите максимальное количество символов в одном слове, при превышение этого значение длинное слово будет автоматически переноситься на новую строчку, данная функция необходима чтобы длинные слова не

испортили общий дизайн сайта

Защита от флуда – Количество секунд в течении которых будет запрещено повторное написание комментария

Смайлики – Перечислите через запятую названия файлов со смайликами, которые будут использоваться при добавлении новостей или комментариев

Коррекция временных зон – Указывается в минутах, необходимо для синхронизации времени сервера со временем с учетом вашего часового пояса, допускаются также и отрицательные значения, если ваше время меньше времени сервера

Автоматическое уменьшение загруженной картинки – Указывается максимальная длина одной из сторон загружаемой картинки, если какая либо сторона по горизонтали или по вертикали превышает указанное значение, то картинка будет уменьшена до этого значения с сохранением пропорций.

Формат времени для новостей – указывается формат в котором будет выводится дата публикации новости

Включить gzip сжатие – Включает передачу контекста в сжатом виде, экономя при этом трафик

Скрывать ссылку на полую новость – скрывает ссылку на полную новость, если новость при этом отсутствует

Комментарии для зарегистрированных – Если установлено «Да» то комментарии смогут добавлять только зарегистрированные на сайте посетители

Разрешить редактирование комментариев – Если установлено «Да» то посетители смогут редактировать свои собственные комментарии, администратор может редактировать комментарии всегда

Разрешить удаление комментариев - Если установлено «Да» то посетители смогут удалять свои собственные комментарии

Формат времени для комментариев - указывается формат в котором будет выводится дата публикации комментария

Включить ЧПУ - Если установлено «Да» то будет включена поддержка ЧПУ

Разрешить фиксацию новостей - Если установлено «Да» то новости при добавлении можно будет фиксировать, фиксация новостей доступна только пользователю со статусом Администратор

Включить кеширование на сайте - Если установлено «Да» то будет включено кеширование страниц, при это теряется часть динамики сайта, до тех пор пока не обновиться кеш, однако включение данного параметра рекомендуется для сайтов с большой посещаемостью.

Включить голосование на сайте - Если установлено «Да» то будет включен модуль голосований на сайте

Включить счетчик просмотров новостей - Если установлено «Да» то будет включен счетчик показывающих сколько раз была просмотрена та или иная статья на сайте

Включить календарь - Если установлено «Да» то будет включен вывод календаря на странице, отключение календаря позволяет сэкономить один запрос к базе данных

Включить вывод архивов - Если установлено «Да» то будет выводиться архив по месяцам, отключение данной функции позволяет сэкономит один запрос к базе данных

Включить поддержку регистрации на сайте - Если установлено «Да» то будет разрешена регистрация посетителей на сайте, отключение данной функции позволяет сэкономить 2 запроса к базе данных, поэтому если вы считаете что регистрация на сайте вам не нужна то просто отключите эту функцию

Способ регистрации на сайте - Возможно два варианта, простой и расширенный при включении расширенного способа будет производиться проверка введенного E-Mail адреса. Пользователь будет должен активировать свой аккаунт при получении соответствующего письма

Разрешить смену скинов посетителями сайта – Если вы установили на сайт несколько шаблонов, то ваши посетители смогут их выбирать по своему усмотрению.

Максимальное количество зарегистрированных пользователей – Максимальное количество пользователей допустимых к регистрации, если указать 0, то регистрация будет осуществляться без ограничений

Автоматическое удаление зарегистрированных пользователей – количество дней через которое будет удален пользователь если он не посещал сайт, если указать 0, то ограничений не будет

Размер фотографии – Максимальный размер любой из сторон фотографии в профиле пользователя, при превышении данного параметра фотография будет автоматически изменена до указанного размера с сохранением пропорций.

Разрешить накладывание водяного знака – Если разрешить то на все загруженные картинки будет наложен водяной знак

Минимальный размер для накладывания водяного знака – Минимальный размер любой из сторон изображения, до которого водяной знак накладываться не будет

Разрешить пользователям загружать картинки - При добавлении новостей с сайта, вы можете своим посетителям разрешить или запретить загрузку картинок на сервер.

Максимально допустимый объём изображения - Если вы разрешили своим посетителям загрузку картинок на сервер, то вы можете ограничить максимальный объем картинки

Автоматическое удаление изображений - Если посетитель загрузил картинку, но не добавил ее в новость, она будет удалена через казанное количество дней.

Качество сжатия .jpg изображения - Качество сжатия JPEG картинки при копировании на сервер


Голосования

В данном разделе вы можете создавать, редактировать и удалять опросы на сайте. Вы можете создавать опросы которые будут видны на всех страницах сайта, а также опросы которые будут видны только при просмотре определенных категорий.


Статические страницы

Помимо написания динамически изменяемых новостей движок позволяет также написание статических страниц, частое изменение которых не планируется. Для того чтобы создать статическую страницу выберите "Создать новую страницу" после этого напишите название страницы, причем только латинскими буквами, потому что оно будет передаваться в URL сайта для просмотра, также введите описание страницы, это информация только для вас, и последнее создайте шаблон самой страницы, разрешено использование HTML. После создания страницы вы сможете ее просмотреть, изменить, либо удалить.

Адрес статической страницы с использование ЧПУ выглядит так: http://webseite.com/название страницы.html

Адрес статической страницы без ЧПУ выглядит так: http://webseite.com/index.php?do=static&page=название страницы


Группы пользователей

В данном разделе вы можете добавлять и редактировать новые и существующие группы пользователей. При добавлении новой группы пользователей вы выставляете ей доступные категории и права на сайте.

Доступные разделы: Разделы в которые имеет доступ выбранная группа

Доверительные разделы: В случае если разрешаете группе публиковать новости на сайте без предварительной модерации, либо разрешаете редактировать новости других пользователей, то в данном пункте вы указываете какие разделы вы доверяете группе. Редактирование новостей в неуказанных группах будет запрещено. Посетитель всегда может добавлять новости в доступные ему разделы, но если одна из категорий будет не в доверительном разделе то вся новость не будет опубликована без предварительной модерации. Категории в которые неразрешено добавлять новости без модерации выделяются красным цветом при добавлении.

Разрешить доступ в админпанель: данная опция разрешает пользователю доступ в админпанель, но не предоставляет доступа ко всем ее функциям. Разрешается доступ только для добавления или редактирования новостей из админпанели. Доступ ко всем функциям имеют только Администраторы.

Скрывать только полную новость из недоступных разделов: В случае если пользователю запрещен доступ в раздел вы можете выбрать, запретить ему полный доступ, либо запретить только просмотр полных новостей. В случае если вы запретите просмотр только полных новостей вы существенно сократите нагрузку на сервер и время выборки новостей.

Разрешить добавлять новости Вы можете запретить либо разрешить пользователям добавлять новости на сайт.

Публиковать новости без проверки: Разрешение на публикацию новостей в доверительные разделы без предварительной модерации

Разрешить фиксировать новости: Разрешение пользователям фиксировать новости на сайте

Редактирование собственных новостей: Разрешение пользователям редактировать собственные новости уже после опубликования на сайте

Редактирование всех новостей: Разрешение пользователям редактировать любые новости из доверительных разделов.

Разрешить добавление комментариев: Разрешение пользователям оставлять комментарии на сайте

Изменение своих комментариев: Разрешение пользователям редактировать собственные комментарии

Удаление своих комментариев: Разрешение пользователям удалять собственные комментарии

Изменение всех комментариев: Разрешение пользователям производить изменение любых комментариев

Удаление всех комментариев: Разрешение пользователям проводить удаление любых комментариев на сайте

Просмотр скрытого текста: Разрешение пользователям на просмотр содержимого тега [hide] [/hide]

Разрешить использование PM: Разрешение пользователям использование персональных сообщений на сайте.

Разрешить скачивание файлов: Разрешение пользователям скачивать загруженные на сервер файлы

Использование обратной связи: Разрешение пользователям использовать обратную связь на сайте

Использование поиска по сайту: Разрешение пользователям использовать поиск по сайту

Временное размещение в группе: Вы можете временно размещать пользователей в данной группе, при переносе пользователя в данную группу укажите до какого срока он будет размещен в данной группе, после окончания данного срока, пользователь будет автоматически перемещен в основную группу

Основная группа по окончании лимита: Укажите основную группу пользователя в которую он будет перемещен после окончания срока пребывания во временной группе.


Настройка категорий

В данном разделе вы можете создавать и редактировать категории. При создании новой категории вы указываете ее имя, альтернативное имя категории, путь для иконки категории, выбрать является ли новая категория подкатегорией и где. А также дополнительно вы можете указать какой шаблон будет использоваться при показе статей из данной категории, а также при просмотре этой категории. Иконка является необязательным параметром. Внимание: альтернативное имя задается только латинскими буквами и служит для вывода всех новостей данной категории. Например вы создаете категорию с именем «Софт», и альтернативным именем «soft», то для просмотра всех новостей из указанной новости при включенном ЧПУ в строке браузера необходимо набрать http://website.com/soft/, а при выключенном ЧПУ необходимо набрать http://website.com/?do=cat&category=soft


Дополнительные поля

В данном разделе вы сможете создавать и редактировать дополнительные поля. Дополнительные поля, позволяют облегчать добавление информации на сайт, по умолчанию имеются только два поля, это краткое и полное описание новости. Однако вы можете создать и другие поля для ввода информации, например ссылку на источник или на программу, и настроив вывод поля всего один раз в шаблонах, отпадает необходимость постоянного форматирования часто повторяющегося ввода информации.

При добавлении нового поля вы вводите его название (латинскими буквами), описание поля (выводится рядом с полем ввода), категорию к которой принадлежит данное поле (вы можете выбрать, вводить ли данное поле для всех категорий или данное поле принадлежать только одной категории, вы можете назначать также выборочно, категории к которым будет принадлежать данное поле, для этого выберите нужные категории в списке удерживая кнопку Ctrl), тип поля (вы можете выбрать три типа поля, либо это одна строка, либо это какой то большой текст, либо это выпадающее меню со списком значений), также можете назначить значение поля по умолчанию. Если вы хотите чтобы поле являлось необязательным при вводе информации, поставьте соответствующую галочку, в противном случае новость не будет добавлена, если данное поле не введено.


Фильтр по IP, Логину или E-Mail

Вы можете воспользоваться данным разделом, чтобы заблокировать определенные IP адреса, или заблокировать определенные электронные адреса, имена пользователей при регистрации. При вводе IP адреса, то доступ на сайт данному IP или подсети закрывается полностью, а не только для регистрации.

Примечание: вы можете воспользоваться в фильтре символом звездочки * для подстановки в имя пользователя, IP адрес или электронный адрес (например: 127.0.*.*, *@mail.ru, username*).


IP утилиты

Данный модуль предназначен, для быстрого и удобного поиска и редактирования пользователей, использовавших для регистрации или авторизации указанный IP адрес. Допускается поиск как по полному IP адресу, так и по сокращенному. Также в данном модуле вы можете найти все IP адреса которые использовал определенный пользователь.


Управление рекламой

Данный модуль предназначен, для быстрого и удобного размещения и управления вашими рекламными материалами на сайте. Для того чтобы разместить на сайте ваш баннер, вам достаточно один раз добавить тег баннера в шаблон, после чего вы можете без проблем менять или редактировать код баннера в админпанели, не затрагивая при этом шаблоны.

После добавления своего баннера вы можете разместить его тег в шаблонах main.tpl или fullstory.tpl. Если вы добавляете баннер для показа между короткими новостями, то добавлять тег в шаблон ненужно, баннер будет добавлен между новостями автоматически.

Пример работы:

- Название: header
- Описание: Верхний баннер
- Включить показ баннера: Да
- Показывать только на главной: Нет
- Закрепить в расположении: Нет
- Расположение в коротких новостях: Нет

Если вы хотите чтобы данных баннер показывался только для определенных групп, то вы можете выбрать при добавлении баннера те группы пользователей, для которых необходимо показывать данный баннер. Также вы можете установить дополнительно время и дату начала показа баннера и время и дату окончания показа

После этого вы можете добавить в ваш шаблон в main.tpl или fullstory.tpl тег для вывода баннера: {banner_header}

Вы можете при добавлении кода баннера использовать HTML и JavaScript.


Анализ производительности

В данном разделе производится анализ всех настроек скрипта и настроек групп пользователей, и по результатам анализа выдаются рекомендации по изменению и отключению тех или иных возможностей скрипта. При этом результаты выводятся с подробными описаниями, почему нужно отключить ту или иную возможность, а также результаты выводятся в специальных графически выделенных блоках, определяющих степень нагрузки той или иной возможности. Рекомендации выделенным красным, необходимо выполнять в первую очередь, т.к. позволяют снизить существенно нагрузку на сервер. Рекомендации в желтом блоке указывают на среднюю степень нагрузки. Рекомендации, выделенные зеленым, способны лишь незначительно снизить нагрузку. Тем самым использование данного раздела рекомендуется в первую очередь, тем, кто испытывает проблемы с нагрузкой на сайт, на своем хостинге и хочет попытаться решить проблему "малой кровью", без смены тарифного плана на хостинге и перехода на более мощные ресурсы. Данный раздел будет полезен как новичкам, недавно пользующимся скриптом, так и более опытным пользователям.


Система Вопрос - Ответ

В админпанели в специальном разделе администратором сайта задается список вопросов и варианты ответа на данные вопросы. При этом данная система может включаться отдельно для регистрации, добавления новостей, добавления комментариев. Для регистрации посетителей на сайте, система включается в настройках скрипта, а для добавления новостей и комментариев включается в настройках групп, и может включаться только для некоторых групп пользователей. Данная система вопроса-ответа является полностью автономной и независимой от каптчи на сайте и может использоваться как совместно с каптчей, так и отдельно. Для вывода системы вопроса и ответа используются шаблонные теги [question] и [/question], которые выводят текст заключенный в данные теги если система вопрос-ответ включена и тег {question} который выводит вопрос для посетителя.


Система логов админпанели

В данном разделе собираются все действия пользователей, осуществляемых в админпанели скрипта, за последние 30 дней, тем самым администратор сайта может всегда посмотреть, какие действия осуществлял тот или иной пользователь админпанели. Собираемые скриптом данные удалить в скрипте нельзя, они автоматически удаляются скриптом по истечении 30 дней, с момента их осуществления.


RSS информер

Данный модуль предназначен для публикации новостей ваших партнеров с других сайтов в определенном блоке на вашем сайте. Зайдя в админпанель для добавления нового информера вы задаете ему следующие параметры:

Название RSS информера - в данном поле вы указываете имя для информера имя может быть уникальным а может быть таким же как и у других информеров. В случае если имя одинаковое то информеры показываются в режиме ротации.

Описание RSS информера - краткое описание предназначенное для вас этого информера

Категория - вы можете указать категорию в которой показывать этот информер, либо сделать доступным показ во всех категориях

URL для RSS информера - здесь вы указываете путь к RSS источнику из которого будут братся новости

Шаблон для информера - укажите шаблон который будет подгружатся для показа отформатированной информации в этом блоке. Например informer.tpl

Количество новостей в блоке - укажите количество новостей которые должны показываться в данном блоке

Количество символов в заголовке - укажите максимальное количество символов в заголовке, при превышении данного лимита заголовок будет автоматически обрезаться. Вы можете установить значение 0, тогда заголовок будет импортироватся целиком

Количество символов в тексте новости- укажите максимальное количество символов в новости, при превышении данного лимита новость будет автоматически обрезаться. Вы можете установить значение 0, тогда новость будет импортироватся целиком


Используемые классы CSS

DataLife Engine использует следующие классы CSS:

.calendar - Вывод таблицы календаря

.monthlink - Ссылка перехода по месяцам в календаре

.day-active-v - Класс для рабочих дней если новости есть

.day-active - Субботние и воскресные дни в которых есть новости
.day - Класс для рабочих дней если новостей нет
.weekday - Субботний и воскресный дни в которых нет новостей

.day-current - Текущая дата, или если посетитель просматривает новости за данный день

.archives - Вывод списка архивов

.xfields - Ввод дополнительный полей в добавлении новости

.rating - Вывод рейтинга

.quote - Используется для вывода цитаты или информации о скрытом тексте

.scriptcode - Используется для вывода информации, заключенной в тег [CODE]

.pm - Таблица при выводе списка полученных приватных сообщений

.pm_head - Заголовок таблицы

.pm_list - Список самих сообщений

.pm_progress_bar - Шкала заполненности ящика персональных сообщений

#dropmenudiv - Выпадающее меню при использовании быстрого или полного редактирования

#newpm, #newpmheader - Для настройки уведомления о получении нового персонального сообщения

.editor_button,

.editor_buttoncl,

.editbclose, .editor_button_brk - Стили для настройки кнопок BB редактора при быстром редактировании новостей на сайте.

.editor - общий стиль для BB редактора.

.clouds_xsmall, .clouds_small, .clouds_medium, .clouds_large, .clouds_xlarge - Для настройки размеров различных ключевых слов в облаке тегов, в зависимости от их популярности

.highslide-active-anchor, .highslide-image-blur, .highslide-html-content, .highslide-loading, a.highslide-full-expand, .highslide-display-block, .highslide-display-none - Для настройки показа всплывающего окна с оригинальным изображением из уменьшенной копии

.highslide-dimming - Используется для задания затемняющего фона при включении режима "Галереи" для показа загруженных изображений.

#loading-layer - оформление информационного окна о выполнении AJAX действия.

#searchsuggestions - оформление быстрого поиска на сайте.

.mass_comments_action - оформление меню выбора действия над комментариями на сайте.

Не забудьте использовать данные стили в вашем главном шаблоне.


Общая информация

DataLife Engine позволяет использовать шаблонную систему для вывода новостей, а также для вывода различных модулей. Мы попытались максимально упростить использование шаблонов в движке, для того чтобы их использовать вам не надо обладать никакими знаниями языков программирования, только язык верстки HTML. Однако для более полного и легкого использования шаблонов мы рекомендуем вам внимательно прочитать руководство по работе с шаблонами, чтобы выяснить какие теги используются в шаблонах и для чего они предназначены.

Шаблоном в DLE является папка которая находится в свою очередь в папке /temlates/. Файлы находящиеся в папке шаблона, являются файлами одного шаблона.

Также вы можете подключать один файл шаблона в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов. Данный тег действует во всех шаблонных файлах .tpl Подключаемый файл должен находится в папке вашего шаблона или его вложенных папках, подключать данным тегом файлы которые не находятся в данном шаблоне, или которые находятся за пределами шаблонов, нельзя.

Теги в подключаемом шаблоне должны быть такие же, какие допустимы в шаблоне где подключается файл, например если файл my_block.tpl подключается в шаблоне main.tpl, то и теги в этом файлы будут работать только те которые возможны в main.tpl


Главная страница сайта

Вывод данного раздела настраивается в файле main.tpl В этом разделе настраиваются шаблоны вашей главной и основной страницы, куда подключаются другие компоненты движка. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно.

{headers} | Выводит сгенерированные метатеги о кодировке страницы, title, keywords, description. А также подключает все необходимые скрипты. Размещаеться в шаблоне между тегами <head>. Данный тег обязателен в шаблоне.
{THEME} | Путь к выбранному шаблону
{login} | Вставка панели для входа и регистрации посетителей
{vote} | Вставка опроса на сайте
{changeskin} | Вставка формы для смены скинов на сайте
{calendar} | Вставка модуля календаря
{topnews} | Вывод самых рейтинговых статей, добавленных за последний месяц
{archives} | Вывод архивов
{info} | выводит служебную информацию движка, в случае если возникла необходимость. Присутствие тега обязательно в шаблоне.
{content} | Вывод непосредственно самого контекста на сайте, новостей, обратной связи регистрации и прочего, в общем основная колонка. Присутствие тега практически обязательно в шаблоне, за исключением крайне редких случаев, в зависимости от необходимых возможностей самого сайта.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[aviable=раздел]текст[/aviable] | Смотрите раздел "Вывод новостей на страницах"
{AJAX} | Подключает все необходимы скрипты для работы DLE и AJAX, подключение обязательно, и рекомендуется размещение в начале страницы, сразу после тега <body>. Данный тег обязателен в шаблоне.
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
{banner_имя} | этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.
{inform_имя} | этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[not-category=X]текст[/not-category]

Предназначен для вывода текста если пользователь находится везде, кроме как в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую

[not-group=X]текст[/not-group] | Вывод текста любой группе пользователей, кроме указанной. Где X это список ID через запятую группы пользователей для которых непоказывать информацию.
[page-count=1,2,3] текст [/page-count] | Выводит текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации.
[not-page-count=1,2,3] текст [/not-page-count] | Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.
[related-news] {related-news} [/related-news] | Выводят блок похожих новостей при просмотре полной новости.


Панель авторизации на сайте

Вывод данного раздела настраивается в файле login.tpl В данном разделе настраивается вывод панели авторизации посетителя на сайте. Возможно использование следующих тегов:

{registration-link} | Ссылка на страницу регистрации посетителя
{lostpassword-link} | Ссылка на страницу восстановления пароля
{logout-link} | Ссылка на разлогинивание пользователя на сайте
{admin-link} | Ссылка на админпанель скрипта
{pm-link} | Ссылка на страницу персональных сообщений
{new-pm} | Количество новых персональных сообщений
{all-pm} | Общее количество персональных сообщений
{favorite-count} | Количество новостей, добавленных пользователем себе в закладки на сайте
{foto} | Ссылка на аватар пользователя.
[admin-link] и [/admin-link] | Выводит текст в тегах, если пользователь имеет доступ к админпанели скрипта
{profile-link} | Ссылка на профиль пользователя
{stats-link} | Ссылка на статистику на сайте
{addnews-link} | Ссылка на страницу добавления новости на сайте
{favorites-link} | Ссылка на просмотр закладок пользователя
{newposts-link} | Ссылка на просмотр непрочитанных новостей пользователем с последнего посещения им сайта
{group-icon} | Выводит иконку группы пользователя
{login-method} | В зависимости от установленного в настройках скрипта типа авторизации, вывод что необходимо вводить пользователю: логин или E-mail


Краткое содержание

Вывод кратких новостей настраивается в файле shortstory.tpl и возможно использование следующих тегов:

{title} | - Выводится заголовок статьи
{title limit="x"} | - Выводится урезанный до X количества символов, заголовок новости.
{news-id} | - ID номер новости, это номер под которым данная новость храниться в базе данных
{short-story} | - Выводится краткая новость
{short-story limit="x"} | - Выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов.
{author} | - Автор статьи
{date} | - Дата публикации, формат вывода даты настраивается в настройках системы
{rating} | - Отображение рейтинга новости
[rating] текст [/rating] | - Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.
{vote-num} | - Выводит количество пользователей, выставивших рейтинг для данной новости
{comments-num} | - Отображает количество комментариев , написанных к статье
{category} | - Категория, к которой относится статья
{category-icon} | - ссылка на иконку категории, внимание выводится именно путь к картинке, сам вывод вы должны предусмотреть самостоятельно например <img src="{category-icon}" />
{views} | - Количество просмотров новости
{favorites} | - Ссылка на добавление или удаление из Избранного
[edit] текст [/edit] | - Ссылка редактирование новости
{link-category} | - Ссылка на все категории в которой присутствует новость
[full-link] и [/full-link] | - Ссылка на полную версию, например [full-link]Подробнее…[/full-link]
[com-link] и [/com-link] | - Ссылка на комментарии к статье, выводится только если они разрешены
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | - Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается
[xfnotgiven_X] [/xfnotgiven_X] | - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{edit-reason} | выводит причину редактирования новости
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{approve} | Выводится только при просмотре пользователем собственного профиля и показывает статус его новостей ожидающих модерации
[fixed] текст [/fixed] | выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}
[catlist=1,2....] текст [/catlist] | выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | выводит текст в теге, если новость не принадлежит указанным категориям.
{login} | выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.
[poll] текст [/poll] | выводят текст в данных тегах, если для данной публикации задан опрос.
[not-poll] текст [/not-poll] | выводят текст в данных тегах, если для данной публикации не был задан опрос.
[profile] текст [/profile] | выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.
{category-url} | Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.
[comments] текст [/comments] | Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.
[not-comments] текст [/not-comments] | Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте.
{image-x} | выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости
[image-x] текст [/image-x] | выводят текст указанный в них только в случае если картинка с номером X присутствует в новости
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.


Статья целиком

Вывод статьи целиком настраивается в файле fullstory.tpl и возможно использование следующих тегов:

{title} | - Заголовок статьи
{title limit="x"} | - Выводится урезанный до X количества символов, заголовок новости.
{full-story} | - Полная версия
{short-story} | - Краткая версия новости
{full-story limit="x"} | - Выводит только текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов
{author} | - Автор статьи
{date} | - Дата публикации
{pages} | - Навигация по страницам новости
[pages] текст [/pages] | - Выводят указанный текст в тегах, если новость разбита на несколько страниц при помощи тега {PАGEBREAK} и убирает текст в нем, если новость состоит из одной страницы.
{link-category} | - Ссылка на все категрии в которой присутствует новость
{rating} | - Выводится форма для выставления рейтинга статьи, тонкая настройка выводится производится при помощи CSS класса rating
[rating] текст [/rating] | - Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.
{vote-num} | выводит количество пользователей, выставивших рейтинг для данной новости
{comments-num} | - Позволяет отображать количество комментариев к статье
{category} | - Категория, к которой относится статья
{category-url} | Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.
{category-icon} | - ссылка на иконку категории
{views} | - Количество просмотров новости
{favorites} | - Ссылка на добавление или удаление из Избранного
[edit] текст [/edit] | - Ссылка на редактирование новости
[print-link] и [/print-link] | - Ссылка на версию для печати
[com-link] и [/com-link] | - Ссылка на комментарии к статье только если они разрешены
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | - Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_X] [/xfnotgiven_X] | - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
{related-news} | Выводить ссылки на 5 наиболее подходящих по контексту новостей.
[catlist=1,2....] текст [/catlist] | Выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | Выводит текст в теге, если новость не принадлежит указанным категориям.
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{edit-reason} | выводит причину редактирования новости
{poll} | Подключает шаблон с опросом для новости, если опрос был добавлен к новости.
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
[fixed] текст [/fixed] | выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}
{comments} | выводит комментарии, написанные к данной новости. Данный тег будет полезен тем, кому необходимо разместить комментарии, например общем дизайне полной новости. Данный тег не является обязательным, в случае его отсутствия комментарии будут автоматически расположены скриптом ниже полной новости
{addcomments} | выводит форму добавления комментариев на сайт, совместно с новым тегом {comments} вы можете размещать форму добавления комментариев как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия форма будет автоматически расположена скриптом ниже полной новости
{navigation} | выводит навигацию по комментариям, если комментарии расположены на нескольких страницах, совместно с новым тегом {comments} вы можете располагать навигацию по комментариям как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия навигация будет автоматически расположена скриптом ниже полной новости
{login} | выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.
[related-news] текст [/related-news] | выводят информацию, заключенную в тегах, только если для данной новости присутствуют похожие новости, в противном случае информация удаляется из шаблона.
[poll] текст [/poll] | выводят текст в данных тегах, если для данной публикации задан опрос.
[not-poll] текст [/not-poll] | выводят текст в данных тегах, если для данной публикации не был задан опрос.
[profile] текст [/profile] | выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[comments] текст [/comments] | Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.
[not-comments] текст [/not-comments] | Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте
{image-x} | Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости
[image-x] текст [/image-x] | Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости
{fullimage-x} | Выводит URL картинки, находящийся в тексте полной новости, где "x" это номер картинки в новости
[fullimage-x] текст [/fullimage-x] | Выводят указанный в них текст, только если картинка с номером "x" присутствует в полной новости.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | выводит текст на любых других страницах кроме просмотра указанных в теге новостей.


Предосмотр новостей

Вывод данного раздела настраивается в файле preview.tpl В этом разделе настраиваются шаблоны, предназначенные для предосмотра добавляемых новостей. В данном шаблоне вы можете использовать все теги для краткой и полной новости, а также статических страниц, при этом для разделения просматриваемых частей используются дополнительно теги:

[short-preview] и [/short-preview] выводит в тегах текст шаблона предназначенного для просмотра краткой новости

[full-preview] и [/full-preview] выводит в тегах текст шаблона предназначенного для просмотра полной новости

[static-preview] и [/static-preview] выводит в тегах текст шаблона предназначенного для просмотра статической страницы


Опросы в новостях

Вывод данного раздела настраивается в файле poll.tpl В данном разделе настраивается вывод опроса для опубликованной новости

{title} | - Заголовок опроса
{question} | - Вопрос
{votes} | - Общее количество голосов
{list} | - Список вариантов ответа
[voted] текст [/voted] | - выводят текст в тегах если пользователь уже проголосовал в опросе, в противном случае его скрывают
[not-voted] текст [/not-voted] | - выводят текст в тегах если пользователь еще не проголосовал в опросе, в противном случае его скрывают


Добавление новости

Вывод данной формы настраивается в файле addnews.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении новости в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{category} | Выводится поле для выбора категории к которой будет принадлежать категория
{xfields} | Вывод дополнительных полей (подробнее о применении смотрите в тестовой шаблоне)
{bbcode} | Выводятся кнопки для вставки тегов в новости
{admintag} | Вывод дополнительных опций для администратора
[urltag] и [/urltag] | Выводится код заключенный в теги, для изменения ЧПУ URL статьи (доступно администратору)
[not-wysywyg] и [/not-wysywyg] | Выводится текст заключенный в теги если отключен WYSIWYG редактор, если включен, то содержимое тегов удаляется
{shortarea} | Выводит WYSIWYG редактор для добавления краткой новости
{title} | Выводит заголовок во время редактирования новости
{alt-name} | Значение ЧПУ при редактировании новости
{short-story} | Короткая новость при редактировании новости
{full-story} | Полная новость при редактировании новости
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении новостей
{sec_code} | Код отображения CAPTCHA
{fullarea} | Выводит WYSIWYG редактор для добавления полной новости
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
{votetitle} | Выводит заголовок опроса при редактировании новости
{frage} | Выводит вопрос из опроса при редактировании новости
{votebody} | Выводит список вариантов ответа из опроса при редактировнии новости


Комментарии

Вывод данного раздела настраивается в файле comments.tpl В данном разделе настраивается вывод комментариев для статьи.

{author} | - Имя человека, оставившего комментарий
{mail} | - е-mail человека, оставившего комментарий
{date} | - Дата публикации комментария, формат вывода даты настраивается в настройках системы
{comment} | - Текст комментария
{comment-id} | - Идентификационный номер комментария
{ip} | - IP адрес человека, оставившего комментарий, просмотр доступен только администраторам сайта
[com-edit] и [/com-edit] | - Ссылка на редактирование комментария только если это разрешено
[com-del] и [/com-del] | - Ссылка на удаление комментария только если это разрешено
{news_title} | - Выводит ссылку на новость при просмотре последних комментариев, при выводе комментариев в новости тег вырезается
{foto} | - Выводит ссылку на фотографию
{fullname} | - Выводит полное имя пользователя
{icq} | - Выводит номер ICQ
{land} | - Выводит место жительства
[signature] и [/signature] | - Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | - Выводит подпись пользователя
{registration} | - Выводит дату регистрации на сайте
{lastdate} | - Выводит дату последнего посещения сайта пользователя.
[fast] [/fast] | - Быстрое цитирование комментариев
{group-icon} | - выводит иконку группы участника
{group-name} | - выводит имя группы участника
{news-num} | - Выводит количество новостей участника
{comm-num} | - Выводит количество комментариев участника
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{login} | выводит логин автора комментария без каких либо ссылок и меню
[profile] текст [/profile] | выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий
{mass-action} | устанавливает возможность массовой отметки комментариев для выполнения массовых действий на сайте
[complaint] текст [/complaint] | Выводять текст, указанных в тегах в виде ссылки на написание жалобы, на комментарий.
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | - Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[fullname] текст [/fullname] | - Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | - Выводится текст, заданный в них только если полное имя пользователя не задано
[icq] текст [/icq] | - Выводится текст заключенный в них только если ICQ пользователя задано
[not-icq] текст [/not-icq] | - Выводится текст, заданный в них только если ICQ пользователя не задано
[land] текст [/land] | - Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | - Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | - Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | - Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[online] текст [/online] | - выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | - выводят текст если пользователь оффлайн
[spam] Спамер [/spam] | - выводят текст, указанных в них, в виде ссылки, при нажатии на которую происходит отметка посетителя, оставившего комментарий, как "спамера"


Форма добавления либо изменения комментария

Вывод данного раздела настраивается в файле addcomments.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении комментариев в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{title} | - Выводит заголовок, для чего эта форма, для добавления или редактирования комментариев
[not-logged] и [/not-logged] | - выводится код заключенный в теги, если пользователь не зарегистрирован, например вы можете заключить в эти теги поля для ввода имени и e-mail адреса, если они не заполнены и пользователь авторизован на сайте, эти данные будут взяты автоматически из его профиля.
{editor} | выводит в зависимости от настроек BBCODE или WYSIWYG редактор для добавления комментария
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении комментариев
{sec_code} | Код отображения CAPTCHA
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | выводит вопрос для посетителя из заданного ранее списка вопросов и ответов


Предыдущая и следующая страницы для новостей

Вывод данного раздела настраивается в файле navigation.tpl В данном разделе настраивается вывод навигации для новостей

[prev-link] and [/prev-link] | - Создает ссылку на предыдущую страницу (если такая есть)
[next-link] and [/next-link] | - Создает ссылку на следующую страницу (если такая есть)
{pages} | - Создает ссылки на страницы; например: 1 2 3 4


Регистрация на сайте

Вывод данного раздела настраивается в файле registration.tpl В этом разделе настраиваются шаблоны, которые используются при регистрации посетителей на сайте. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[registration] и [/registration] | - Выводит текст заключенный в тегах при регистрации
[validation] и [/validation] | - Выводит текст заключенный в тегах при активации
[sec_code] и [/sec_code] | - Выводит текст заключенный в тегах если разрешен показ кода безопасности
{reg_code} | - Выводит код безопасности для посетителя
{xfields} | Выводит поля для ввода дополнительных полей профиля
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | выводит вопрос для посетителя из заданного ранее списка вопросов и ответов


Информация о посетителе

Вывод данного раздела настраивается в файле userinfo.tpl В этом разделе настраиваются шаблоны, которые используются при выводе профиля пользователя. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{usertitle} | - Вывод имени пользователя
{info} | - Краткая информация о пользователе
{editmail} | - e-mail адрес
{comm-num} | - Количество комментариев
{news-num} | - Количество новостей
{status} | - Статус пользователя
{rate} | - Текущий рейтинг посетителя (складывается автоматически на основе рейтинга его статей)
{registration} | - Дата регистрации на сайте
{editinfo} | - Вывод существующей краткой информации в поле при редактировании профиля
{hidemail} | - скрытие e-mail адреса
{foto} | - выводит ссылку на загруженную фотографию
{fullname} | - выводит полное имя пользователя
{land} | - выводит место жительства
{icq} | - выводит номер ICQ
[not-logged] и [/not-logged] | - выводится код заключенный в теги, если пользователь который просматривает профиль и есть этот самый пользователь, используется для того чтобы посетители могли редактировать свой собственный профиль.
[signature] и [/signature] | - Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | - Выводит подпись пользователя
{editsignature} | - Выводит отформатированную для редактирования подпись пользователя
{lastdate} | - Выводит дату последнего посещения сайта пользователем
{comments} | - Выводит ссылку на все комментарии этого пользователя
{allowed-ip} | Значение IP с которого разрешена авторизация
{xfields} | Список дополнительных полей профиля при их редактировании
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | - Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
{group-icon} | - выводит иконку группы участника
[time_limit] [/time_limit]. | - выводит текст между тегами если пользователь находится во временной группе
{time_limit} | - выводит дату, до которой пользователь находится во временной группе
{news} | - Выводит ссылку на просмотр всех новостей данного пользователя
[rss] тект [/rss] | публикуют ссылку в профиле на RSS поток всех новостей пользователя.
{ignore-list} | Список пользователей, добавленных в игнорируемые.
[fullname] текст [/fullname] | - Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | - Выводится текст, заданный в них только если полное имя пользователя не задано
[icq] текст [/icq] | - Выводится текст заключенный в них только если ICQ пользователя задано
[not-icq] текст [/not-icq] | - Выводится текст, заданный в них только если ICQ пользователя не задано
[land] текст [/land] | - Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | - Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | - Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | - Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[online] текст [/online] | - выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | - выводят текст если пользователь оффлайн


Карточка профиля пользователя

Вывод данного раздела настраивается в файле profile_popup.tpl В этом разделе настраиваются шаблоны, которые используются при выводе карточки профиля пользователя.

{fullname} | - выводит полное имя пользователя
{foto} | - выводит ссылку на загруженную фотографию
{status} | - Статус пользователя
{registration} | - Дата регистрации на сайте
{lastdate} | - Выводит дату последнего посещения сайта пользователем
{comm-num} | - Количество комментариев
{news-num} | - Количество новостей
{icq} | - выводит номер ICQ
{land} | - выводит место жительства
{info} | - Краткая информация о пользователе
{rate} | - Текущий рейтинг посетителя (складывается автоматически на основе рейтинга его статей)
[signature] и [/signature] | - Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | - Выводит подпись пользователя
{group-icon} | - Выводит иконку группы пользователя
{news} | - Выводит ссылку на просмотр всех новостей данного пользователя
{comments} | - Выводит ссылку на все комментарии этого пользователя
[rss] тект [/rss] | - Выводит ссылку в профиле на RSS поток всех новостей пользователя
[fullname] текст [/fullname] | - Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | - Выводится текст, заданный в них только если полное имя пользователя не задано
[icq] текст [/icq] | - Выводится текст заключенный в них только если ICQ пользователя задано
[not-icq] текст [/not-icq] | - Выводится текст, заданный в них только если ICQ пользователя не задано
[land] текст [/land] | - Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | - Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | - Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | - Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | - Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | - Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[online] текст [/online] | - выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | - выводят текст если пользователь оффлайн


Форма поиска

Вывод данного раздела настраивается в файле search.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод формы поиска по сайту:

{searchtable} | - Форма поиска в виде таблицы
{searchmsg} | - Вывод сообщения о результатах поиска
[searchmsg] и [/searchmsg] | - Вывод текста в случае если был произведен поиск


Результаты поиска

Вывод данного раздела настраивается в файле searchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате поиска:

{search-id} | Идентификационный номер найденного элемента
{result-date} | - Дата статьи
{result-title} | - Заголовок статьи
{result-author} | - Автор статьи
{result-text} | - Выводит текст краткой новости
{result-text limit="x"} | - Выводит текст найденной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного "x" количества символов.
{result-comments} | - Число комментариев
[result-link] и [/result-link] | - Ссылка на статью
[searchposts] и [/searchposts] | - Вывод найденных результатов для новостей
[searchcomments] и [/searchcomments] | - Вывод найденных результатов для комментариев
[fullresult] и [/fullresult] | - Вывод результатов в виде статей
[shortresult] и [/shortresult] | - Вывод результатов в виде заголовков
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{favorites} | - Ссылка на добавление или удаление новости из Избранного
{edit-reason} | выводит причину редактирования новости
[catlist=1,2....] текст [/catlist] | выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | выводит текст в теге, если новость не принадлежит указанным категориям.
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.
{image-x} | выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости
[image-x] текст [/image-x] | выводят текст указанный в них только в случае если картинка с номером X присутствует в новости


Статистика сайта

Вывод данного раздела настраивается в файле stats.tpl В данном разделе настраивается вывод общей статистики сайта

{datenbank} | - Общий размер базы данных
{news_num} | - Общее количество новостей
{news_allow} | - Опубликовано новостей
{news_main} | - Опубликовано на главной
{news_moder} | - Ожидает модерации
{comm_num} | - Количество комментариев
{user_num} | - Зарегистрировано пользователей
{user_banned} | - Забаненных пользователей
{topusers} | - Список лучших авторов на сайте
{news_day} | - Опубликовано новостей за сутки
{news_week} | - Опубликовано новостей за неделю
{news_month} | - Опубликовано новостей за месяц
{comm_day} | - Опубликовано комментариев за сутки
{comm_week} | - Опубликовано комментариев за неделю
{comm_month} | - Опубликовано комментариев за месяц
{user_day} | - Зарегистрировано пользователей за сутки
{user_week} | - Зарегистрировано пользователей за неделю
{user_month} | - Зарегистрировано пользователей за месяц


Вывод информации и ошибок

Вывод данного раздела настраивается в файле info.tpl В данном разделе настраивается вывод формы в случае возникновения ошибок, либо наоборот в случае успешного выполнения действий.

{title} – заголовок сообщения

{error} – текст ошибки


Форма для отправки E-Mail

Вывод данного раздела настраивается в файле feedback.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для отправки E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{recipient} - Выводит список получателей

[not-logged] и [/not-logged] - Выводит текст между тегами если посетитель не зарегистрирован

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Восстановление пароля

Вывод данного раздела настраивается в файле lostpassword.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для восстановления пароля на E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Статические страницы

Вывод данного раздела настраивается в файле static.tpl или в файле который вы назначите при создании статической страницы в админпанели скрипта. В данном разделе настраивается вывод общей статистики сайта.

{description} выводит описание статической страницы

{static} выводит текст статической страницы

{pages} Выводит навигацию по нескольким страницам одной статической страницы.

{views} Выводит количество просмотров статической страницы.

{custom} Смотрите раздел "Вывод новостей на страницах"

[print-link] текст [/print-link] выводить ссылку на версию для печати

{date} выводит дату создания страницы в формате установленном в настройках скрипта

{date=формат даты} выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время. Также дополнительно как в тексте статических страниц, так и в их шаблонах вы можете указывать теги из модуля управления рекламой и теги информеров.

[static=имя страницы] текст [/static] выводит текст заключенный в теги , если посетитель просматривает статическую страницу с указанным именем.

[not-static=имя страницы] текст [/not-static] выводит текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.

Также в шаблоне имеется поддержка тегов рекламы и RSS информеров


Персональные сообщения

Вывод данного раздела настраивается в файле pm.tpl В этом разделе настраиваются шаблоны, которые используются для работы с персональными сообщениями. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[inbox] и [/inbox] | - Ссылка на входящие сообщения
[outbox] и [/outbox] | - Ссылка на отправленные сообщения
[new_pm] и [/new_pm] | - Ссылка на написание сообщения
[pmlist] и [/pmlist] | - Выводится текст в тегах, если просматривается список сообщений
{pmlist} | - Список сообщений
[newpm] и [/newpm] | - Выводится текст в тегах, если написание сообщения
{pm-limit} | - Выводит максимальное количество сообщений, который может хранить пользователь
{proc-pm-limit} | - Выводит количество заполненного пространства ящика пользователя в процентах
{pm-progress-bar} | - Выводит шкалу наполненности ящика персональных сообщений
{author} | - Получатель сообщения
{subj} | - Тема сообщения
{editor} | выводит в зависимости от настроек BBCODE или WYSIWYG редактор для написания сообщения
{text} | - Текст сообщения
[readpm] и [/readpm] | - Выводится текст в тегах, если просматривается само сообщение
[reply] и [/reply] | - Ссылка для ответа на сообщение
[del] и [/del] | - Ссылка на удаление сообщения
{sec_code} | Код отображения CAPTCHA
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при написании персональных сообщений
{foto} | - Выводит ссылку на фотографию
{group-icon} | - выводит иконку группы участника
{group-name} | - выводит имя группы участника
{news-num} | - Выводит количество новостей участника
{comm-num} | - Выводит количество комментариев участника
[signature]{signature}[/signature] | - Выводит текст заключенный в теги и подпись пользователя, если пользователь задал подпись в профиле
{date} | - Дата публикации комментария, формат вывода даты настраивается в настройках системы
{registration} | - Выводит дату регистрации на сайте
{icq} | - Выводит номер ICQ
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[complaint] текст [/complaint] | Выводять текст, указанных в тегах в виде ссылки на написание жалобы, на персональное сообщение.
[ignore]текст[/ignore] | Выводять ссылка на добавление пользователя в список игнорируемых.


Облако тегов

Вывод данного раздела настраивается в файле tagscloud.tpl В этом разделе настраиваются шаблоны, которые используются для работы с облаком тегов. В данном блоке показываются все ключевые теги добавленные к новостям.

Возможно использование следующих тегов:

{tags} - Используется для вывода всех ключевых тегов, находящихся в базе данных

{tags limit="100"} - Используется для вывода 100 самых популярных ключевых тегов, находящихся в базе данных


Голосование на сайте

Вывод данного раздела настраивается в файле vote.tpl В этом разделе настраиваются шаблоны, которые используются для работы с голосованием на сайте.

Возможно использование следующих тегов:

{title} - Заголовок опроса

{list} - Список вопросов

{vote_id} - ID опроса

{votes} - Количество голосов

[votelist] и [/votelist] - Выводит текст который нужно показывать для еще не голосовавших людей

[voteresult] и [/voteresult] - Выводит текст который нужно показывать для уже голосовавших людей


Топ новостей

Вывод данного раздела настраивается в файле topnews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода блока популярных новостей.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - Выводится урезанный до X количества символов, заголовок новости.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Похожие новости

Вывод данного раздела настраивается в файле relatednews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода списка похожих новостей при просмотре полной новости на сайте.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости.

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Временное отключение сайта

В данном разделе вы можете настроить страницу, которая будет выводится при отключении сайта например на технические работы. Помните что администраторы всегда будут допущены к просмотру сайта как при включенном режиме. Все остальные будут видеть страницу из данного раздела.

Шаблон настраивается в файле offline.tpl и возможно использование следующих тегов:

{reason} - Используется для вывода причины отключения сайта, которое вы задаете в настройках скрипта


Модуль speedbar

В данном разделе вы можете настроить вывод текущего местоположения пользователя на вашем сайте. Данный шаблон использует только один тег {speedbar} который и выводит непосредственно местоположение.


RSS информер

В данном шаблоне вы можете настроить вывод вашего RSS информера. Имя данного шаблона вы назначаете самостоятельно в админпанели при добавлении нового RSS информера. В данном шаблоне вы можете использовать следующие теги:

[link] текст [/link] - формирует ссылку на новость партнера

{title} - заголовок новости

{news} - непосредственно сама новость

{category} - выводит категорию в которой опубликована новости в RSS потоке

{author} - выводит автора новости

{date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости


OpenSearch

Данный шаблон находится в файле templates/opensearch.tpl и предназначен для поддержки технологии OpenSearch в современных браузерах, данная технология позволяет интегрировать поиск по вашему сайту в строку поиска самого браузера. Будьте предельно внимательны при редактировании данного шаблона. Он должен соответствовать необходимым спецификациям.


Разработка и подключение модулей

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта. Данные механизмы позволяют обеспечить работоспособность и после обновления скрипта на новую версию, т.к. данные механизмы позволяют осуществлять подключение без правки файлов скрипта. Для подключения разработанных вами модулей вам необходимо в любом необходимом вам шаблоне добавить тег:

{include file="engine/modules/mymod.php"}

Где engine/modules/ это путь к файлу вашего модуля, а mymod.php имя подключаемого файла. Стандартные файлы модулей DataLife Engine находятся в этой папке и мы вам рекомендуем использовать данную папку, однако это не является обязательным требованием и файл может находится в любой другой папке на сервере. Единственное ограничение безопасности по подобному подключению модулей, это то что на папку в которой находится файл не должно быть прав на запись (CHMOD 777). Также мы рекомендуем вам использовать именно относительные пути при подключении модулей, DataLfe Engine автоматически распознает относительные пути и подключает ваши модули уже согласно настройкам скрипта и путям где установлен скрипт. Тем самым вы можете создавать универсальные инструкции по установке ваших модификаций.

Также вы можете подключать PHP файлы вашего модуля передав им различные параметры, например:

{include file="engine/modules/mymod.php?param=value1&variable2=value2"}

Благодаря подобному подключению, вы можете делать ваши модификации многофункциональными, которые будут выполнять различные роли и функции при различных подключениях. Переданные переменные будут доступны в вашем модуле как $param и $variable2 соответственно.

Начиная с версии DataLife Engine 8.3 в качестве параметров к подключаемым модулям вы можете задавать шаблонные теги скрипта, например при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это аналоги GET параметров URL браузера, соответственно при выборе передаваемых тегов вы должны учитывать ограчения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.

Также вы можете использовать подключение своих модулей и для замены основного блока, где выводятся новости и другая основная информация, для этого необходимо использовать данный тег совместно с тегами [aviable=раздел]текст[/aviable] и [not-aviable=раздел]текст[/not-aviable] Описание тегов смотрите в документации в разделе "Вывод новостей на страницах". Вы можете использовать как стандартный список разделов, так и использовать создание собственного раздела сайта, передав его в URL браузера. Рассмотрим простейший пример. Вы хотите добавить к стандартным разделам сайта, добавить свой раздел и выводить информацию в нем из вашего модуля. Допустим вы хотите создать раздел FAQ. Для этого в шаблоне main.tpl прописывается конструкция:

[aviable=faq]{include file="engine/modules/mymod.php"}[/aviable]

[not-aviable=faq]{content}[/not-aviable]

После подобного подключения помимо работы стандартных разделов сайта при обращении по адресу: http://site.ru/index.php?do=faq вместо новостей будет выводится ваш новый раздел из вашего модуля.

Для работы ваших модулей и вывода информации именно в том месте шаблона, где вставлен вышеуказанный тег, обязательно только одно важное условие. Вывод информации должен осуществляется только через функцию PHP echo. Рассмотрим пример простейшего модуля и вывода информации. Создадим файл mymod.php со следующим содержимым:

<?php

echo "Тестовый модуль";

?>

При подключении этого файла в шаблоне, в данном месте шаблона появится текст: Тестовый модуль

Список переменных и классов DLE которые вы можете использовать в вашем подключаемом модуле, без дополнительного объявления:

$is_logged - содержит информацию, является ли посетитель авторизованным пользователем или гостем, и содержит значения true или false.

$member_id - содержит массив с информацией о авторизованном пользователе, включая всю его информацию из профиля.

$db - класс DLE для работы с базой данных.

$tpl - класс DLE для работы с шаблонами.

$cat_info - массив содержащий информацию обо всех категориях на сайте.

$config - массив содержащий информацию обо всех настройках скрипта.

$user_group - массив содержащий информацию о всех группах пользователей и их настройках.

$category_id - содержит ID категории которую просматривает посетитель.

$_TIME - содержит текущее время в UNIX формате с учетом настроек смещения в настройках скрипта.

$lang - массив содержащий текст из языкового пакета.

$smartphone_detected - содержит информацию о том, просматривает ли пользователь сайт со смартфона или с обычного браузера, и содержит значения true или false.

$dle_module - содержит информацию о разделе сайта, который просматривает пользователь, либо информацию переменной do из URL браузера.

Внимание: Ваш модуль должен только читать данные из данных переменных, внесение изменений в значения переменных повлечет сбои в работе стандартных возможностей скрипта и дальнейшей его некорректной работе.


Подключение модулей в адмипанели

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта в админпанели. Данные механизмы позволяют подключать модули админпанели без внесения изменений в файлы скрипта и позволяют сохранять работоспособность после обновления скрипта на новую версию скрипта.

Для того чтобы подключить ваш сторонний модуль в админпанель, вы должны разместить файл вашего модуля в папке engine/inc/ это обязательное условие. Только файлы находящиеся в этой папке могут быть подключены. Например имя файла вашего модуля mymod.php вы разместили его в папке engine/inc/ После этого вы можете вызвать и обратится к вашему модулю из админпанели по адресу: http://site.ru/admin.php?mod=mymod где mymod это имя вашего модуля без расширения .php Подключение происходит автоматически, никаких изменений в файлах скрипта не требуется.

Для того чтобы пользователи не вводили адрес вашего модуля в браузере вручную и он отображался в списке всех разделов в административной панели, для этого предусмотрена специальная таблица в базе данных MySQL. Имя таблицы: ПРЕФИКС_admin_sections. ПРЕФИКС ваш скрипт установки может прочитать из файла engine/inc/dbconfig.php. Данная таблица содержит следующие имена полей:

name - содержит имя вашего модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла. Например имя вашего файла mymod.php, то в данное поле должно быть записано значение mymod.

title - содержит заголовок вашего модуля.

descr - содержит описание вашего модуля.

icon - содержит имя иконки для вашего модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/ (это обязательное условие). Рекомендуемые размеры иконок 70 на 70 пикселей.

allow_groups - содержит информацию о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанел.

Пример запроса для записи информации о модуле mymod:

INSERT INTO `префикс_admin_sections` (`name`, `title`, `descr`, `icon`, `allow_groups`) VALUES

('mymod', 'Тестовый модуль', 'Здесь находится описание тестового модуля', 'mymod.png', '1');

после выполнения данного запроса модуль в админпанели будет прописан в админпанели только для администраторов.

ВНИМАНИЕ: указание о группах в базе данных не запрещает и не предотвращяет запуск модуля пользователями из других групп. Для разграничения доступа ваши подключаемые модули обязаны сами производить проверку групп и разрешать выполнение только разрешенным группам.


API для разработки модулей

API предназначен для написания модификаций совместимых со старыми и будущими версиями скрипта. В случае использования API для получения данных из базы, вы можете быть уверенными что данный код будет работать и в будущих версиям, тем самым вы облегчается проверка и адаптация кода при выходе новой версии. Также при использовании API вам нет необходимости писать собственные функции для выборки данных, нет необходимости подключать и объявлять необходимые для работы с БД классы. Достаточно просто подключить файл API, и начать использовать его функции, все остальное он берет на себя.

Для использования API в своем модуле вы должны его подключить строчкой:

include ('engine/api/api.class.php');

При этом вам нет необходимости задумываться есть ли подключение к БД или нет, подключены или нет необходимые классы. Данный код вы можете использовать как внутри файлов самого скрипта DLE, так и просто в других скриптах, не имеющих отношения к DLE. Тем самым вы можете организовывать стандартизированные интеграции скрипта DLE, с другими скриптами. Например форумами.

Список функций API:

$dle_api->take_user_by_id( int $id [, string $select_list] );

получение массива с информацией о пользователе по его ID. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией о пользователе либо false, если пользователь не найден.

$dle_api->take_user_by_name( string $name [, string $select_list]);

получение массива с информацией о пользователе по его логину. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_user_by_email( string $email [, string $select_list]);

получение массива с информацией о пользователе по его E-Mail. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_users_by_group( int $group_id [, string $select_list [, int $limit]]);

получение массива с информацией о пользователях по номеру группы. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->take_users_by_ip( string $ip, [, bool $like [, string $select_list [, int $limit]]]);

Получение списка пользователей по IP, второй параметр $like указывает использовать точное совпадение при поиске, либо неточное. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->change_user_name( int $user_id, string $new_name);

Изменение логина пользователя. user_id ID пользователя, логин которого необходимо заменить. new_name новый логин пользователя. Возвращаемые значения: true если успешно выполнено, false если новое имя уже занято другим пользователем.

$dle_api->change_user_pass( int $user_id, string $new_pass);

Изменение пароля пользователя. user_id ID пользователя, пароль которого необходимо заменить. new_pass новый пароль пользователя.

$dle_api->change_user_email( int $user_id, string $new_email);

Изменение E-Mail пользователя. user_id ID пользователя, E-Mail которого необходимо заменить. new_email новый E-Mail пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый E-Mail уже существует, -2 - некорректный E-mail.

$dle_api->change_user_group( int $user_id, int $new_group);

Изменение группы пользователя. user_id ID пользователя, группу которого необходимо заменить. new_group ID новой группы пользователя. Возвращаемые значения: true если успешно выполнено, false если указан ID несуществующей группы.

$dle_api->external_auth( string $login, string $password);

Авторизация по логину и паролю. Возвращаемые значения: true - авторизация успешна, false - логин или пароль не верны.

$dle_api->external_register( string $login, string $password, string $email, int $group);

Регистрация пользователя в базе данных. В функцию передаются: Логин, Пароль, E-mail и номер группы в которой зарегистрировать пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый логин уже существует, -2 - новый E-Mail уже существует, -3 - некорректный E-Mail, -4 - задана несуществующая группа.

$dle_api->send_pm_to_user ( int $user_id, string $subject, string $text, string $from);

Отправка персонального сообщения пользователю. $user_id ID получателя. $subject тема сообщения. $text текст сообщения. $from логин отправителя. Возвращаемые значения: 1 - успешно выполнено, -1 - получатель не найден, 0 - ошибка БД.

$dle_api->load_table ( string $table [, string $fields [, string $where [, bool $multirow [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]]]);

Получение информации из таблицы БД.

$table - название таблицы

$fields - необходимые поля через запятую или * для всех

$where - условие выборки

$multirow - забирать ли один ряд или несколько

$start - начальное значение выборки

$limit - количество записей для выборки, 0 - выбрать все

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращается массив с данными, либо false если в БД по указанным параметрам ничего не найдено.

$dle_api->save_to_cache ( string $fname, mixed $vars);

Запись данных в файл кеша. Параметр $fname указывает имя файла кеша без указания его расширения. $vars - данные для записи в кеш.

$dle_api->load_from_cache ( string $fname, [, int $timeout [, string $type]]);

Чтение данных из файла кеша. Параметр $fname указывает имя файла кеша без указания его расширения. Необязательный параметр $timeout указывает количество секунд, в течении которых информацию из кеша считать актуальной. Если файл кеша будет устаревшим, то функция возвращает false. Необязательный параметр $type указывает на тип данных который хранится в кеше, если не 'text' - считаем, что хранился массив и возвращается массив данных.

$dle_api->clean_cache ( [string $name] );

Удаление кеша. Необязательный параметр $name указывает на конкретное имя файла без расширения который нужно удалить

$dle_api->get_cached_files();

Получение массива содержащего названия файлов кеша.

$dle_api->edit_config ( mixed $key, [, string $new_value]);

Изменение и сохранение настроек скрипта.

Параметр $key string или array

string: Название параметра

array: ассоциативный массив параметров

Параметр $new_value - значение параметра. Не используется, если $key массив

$dle_api->take_news ( string $cat, [, string $fields [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]);

Получение новостей

$cat - категории новостей, через запятую

$fields - перечень получаемых полей новостей или * для всех

$start - начальное значение выборки

$limit - количество новостей для выборки, 0 - выбрать все новости

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращает ассоциативный 2-х мерный массив с новостями

$dle_api->checkGroup ( int $group );

Проверяет существует ли указанная группа или нет. Возвращаемые значения: true если группа существует, false если группа не существует.

$dle_api->install_admin_module ( string $name, string $title, string $descr, string $icon [, string $perm] );

Установка стороннего модуля в админпанель скрипта.

$name - название модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла

$title - заголовок модуля

$descr - описание модуля

$icon - имя иконки для модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

$dle_api->uninstall_admin_module ( string $name );

Удаление стороннего модуля из админпанели скрипта.

$name - название удаляемого модуля

$dle_api->change_admin_module_perms ( string $name, string $perm );

Изменение группы пользователей которым разрешен показ стороннего модуля в админпанели скрипта.

$name - название модуля

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

Разработка полноценного API, только начата и на данный момент API имеет пока ограниченный набор функций. Поэтому мы просим всех заинтересованных в данном API разработчиков посетить специально созданную для этого тему на форуме и оставить свои пожелания о том какие новые функции вы хотите видеть в новых версиях. Потому что только опираясь на ваши потребности можно создать полноценный API, охватывающий все аспекты взаимодействия с скриптом.


Запуск функций по крону

В DataLife Engine присутствует возможность запускать некоторые функции по расписанию. Вы можете создавать автоматически бекап БД, оптимизировать БД, а также создавать карту сайта для поисковиков. Для этого необходима поддержка вашим хостингом функции запуска приложений по расписанию (CRON). Для запуска функций по крону предназначен файл cron.php расположенный в корне вашего сайта. По умолчанию в целях безопасности возможность запуска этого файла отключена, поэтому рассмотрим как можно включить данную функцию.

Во первых мы рекомендуем обязательно в целях безопасности изменить название файла cron.php на любое другое с расширением .php

Далее откройте этот файл в текстовом редакторе и в самом начале найдите строчку

$allow_cron = 0;

Измените ее на

$allow_cron = 1;

Тем самым вы разрешаете этому файлу выполнять функции в автоматическом режиме.

Далее вы можете изменить количество файлов резервных копий БД которые будут хранится на сервере. Для этого найдите чуть ниже строчку

$max_count_files = 5;

где 5 это количество копий БД. Вы можете поставить свое собственное количество файлов. При превышении данного лимита более старые резервные копии базы данных будут автоматически удалятся.

После того как вы произвели необходимые изменения, сохраните данный файл на сервере. Теперь вам нужно добавить данный файл на запуск по расписанию (CRON) время создания и периодичность вы устанавливаете самостоятельно. Подробную инструкцию по добавлению данного файла в функцию CRON вы можете получить у вашего хостинг провайдера.

Файл крона может выполнять следующие операции:

1. Создание резервной копии базы данный. Для запуска данного режима

просто запустите файл cron.php без указания ему параметров

2. Создание карты сайты сайта. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=sitemap

если используется консольный запуск скрипта, то используйте php -f cron.php sitemap

При создании карты сайта по крону, также будет выполняться автоматическое уведомление поисковых систем о наличии карты сайта.

3. Оптимизация базы данных. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=optimize

если используется консольный запуск скрипта, то используйте php -f cron.php optimize

4. Запуск антивируса. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=antivirus

если используется консольный запуск скрипта, то используйте php -f cron.php antivirus

При этом конечно не следует забывать про указание правильных путей как к PHP интерпретатору, так и к самому скрипту от корня вашего сервера.


RSS Экспорт

Движок DataLife Engine поддерживает также экспорт новостей в формате RSS для того чтобы посетители получили экспорт новостей с главной страницы вы должны использовать следующий путь.

http://website.com/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php - без использования ЧПУ

Для экспорта новостей из определенной категории используйте следующие ссылки

http://website.com/альтернативное имя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?do=cat&category=альтернативное имя - без использования ЧПУ

Для экспорта всех новостей определенного пользователя используйте следующие ссылки

http://website.com/user/имя пользователя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?subaction=allnews&user=имя пользователя - без использования ЧПУ

Для экспорта новостей из определенного каталога используйте следующие ссылки

http://website.com/catalog/идентификатор/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?catalog=идентификатор - без использования ЧПУ